现在的位置: 首页 > 综合 > 正文

寒假前刷题(9)搜索系列 bfs hdu 1312

2013年05月08日 ⁄ 综合 ⁄ 共 2890字 ⁄ 字号 评论关闭


Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 4527    Accepted Submission(s): 2945

Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.Write a program to count the number of black tiles which he can reach by repeating the moves described above.
 
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.'.' - a black tile '#' - a red tile '@' - a man on a black tile(appears exactly once in a data set)
 
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
 
Sample Input
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#..
0 0
Sample Output
45 59 6 13
这是一道bfs的搜索题,只要按照4个方向来搜索即可。
下面是代码:

#include<stdio.h>
#include<stdlib.h>
#include<iostream>

using namespace std;

char str[30][30];
int flag[30][30];
int count;
int w,h;
int dir[4][2]={1,0,0,-1,-1,0,0,1}; //遍历数组

void bfs(int x,int y)
{
     int i;
     int ex,ey;
     for(i=0;i<4;i++)
     {
          ex=x+dir[i][0];
          ey=y+dir[i][1];
          if(ex<0||ex>=h||ey<0||ey>=w)
            continue; //记住不是break,也不是return,这里如果越界了,就返回到下一次循环
          if(flag[ex][ey]==0)
          {
                flag[ex][ey]=1;
                count++;
                bfs(ex,ey);
          }
     }
}

int main()
{
     int i,l;
     int sx,sy;
     while(scanf("%d%d",&w,&h)!=-1)
     {
          if(w==0&&h==0)
              break;
          for(i=0;i<h;i++)
          {
               scanf("%s",str[i]);
                 for(l=0;str[i][l];l++)
                 {
                      if(str[i][l]=='@')
                      {
                           sx=i;
                           sy=l;
                           flag[i][l]=1;
                      }
                      if(str[i][l]=='.')
                          flag[i][l]=0;
                      else
                      flag[i][l]=1;
                 }
          }
          count=1;
          bfs(sx,sy);
          printf("%d\n",count);
     }
     return 0;
}


查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场

抱歉!评论已关闭.