现在的位置: 首页 > 综合 > 正文

NYOJ—a letter and a number —215

2013年02月24日 ⁄ 综合 ⁄ 共 617字 ⁄ 字号 评论关闭

a letter and a number

时间限制:3000 ms  |  内存限制:65535 KB
难度:1
描述
we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, ... f(Z) = 26, f(z) = -26;
Give you a letter x and a number y , you should output the result of y+f(x).

输入
On the first line, contains a number T(0<T<=10000).then T lines follow, each line is a case.each case contains a letter x and a number y(0<=y<1000).
输出
for each case, you should the result of y+f(x) on a line
样例输入
6
R 1
P 2
G 3
r 1
p 2
g 3
样例输出
19
18
10
-17
-14
-4

#include<stdio.h>
int main(){
    int n;
    scanf("%d",&n);
    getchar();
    int a;
    char b;  
    while(n--){
		int sum=0;
		scanf("%c %d",&b,&a);
		if(b>='A'&&b<='Z'){
			sum=b-'A'+1+a;
			printf("%d\n",sum);
			getchar(); 
		}
		if(b>='a'&&b<='z'){
			sum=-b+96+a;
			printf("%d\n",sum);
			getchar();
		}
               
    }
    return 0;
}


抱歉!评论已关闭.