现在的位置: 首页 > 综合 > 正文

杭电OJ——1098 Ignatius’s puzzle

2013年03月22日 ⁄ 综合 ⁄ 共 814字 ⁄ 字号 评论关闭

Ignatius's puzzle




Problem Description
Ignatius is poor at math,he falls across a puzzle problem,so he has no choice but to appeal to Eddy. this problem describes that:f(x)=5*x^13+13*x^5+k*a*x,input a nonegative integer k(k<10000),to find the minimal nonegative integer a,make the arbitrary integer
x ,65|f(x)if
no exists that a,then print "no".

 


Input
The input contains several test cases. Each test case consists of a nonegative integer k, More details in the Sample Input.
 


Output
The output contains a string "no",if you can't find a,or you should output a line contains the a.More details in the Sample Output.
 


Sample Input
11 100 9999
 


Sample Output
22 no 43
 

这道题目难点不在编程,在数学!数学归纳法证明! 最后只要证明 18 + k * a 能整除65就可以了。

代码:

#include<stdio.h>

 int main ()
 {
     int a = 0;
     int k = 0;

     while ( scanf ( "%d" , &k ) != EOF )
     {
           if ( k % 65 == 0 )
           {
                printf ( "no\n" ) ;
                continue ;
           }
           for ( a = 1 ; a <= 65 ; ++ a )
           {
               if ( ( 18 + k * a ) % 65 == 0 )
               {
                    printf ( "%d\n" , a ) ;
                    break ;
               }
           }
           if ( a > 65 )
           {
                printf ( "no\n" ) ;
           }
     }
     return 0 ;
 }

抱歉!评论已关闭.