现在的位置: 首页 > 综合 > 正文

poj 1007

2013年08月17日 ⁄ 综合 ⁄ 共 2041字 ⁄ 字号 评论关闭

http://poj.org/problem?id=1007

代码:

/*DNA Sorting
Time Limit: 1000MS		Memory Limit: 10000K
Total Submissions: 56496		Accepted: 22147
Description

One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted). 

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length. 
Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.
Output

Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.
Sample Input

10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT
Sample Output

CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA
*/

#include <iostream>
using namespace std;
const int maxinver = 10000;
int getMinIndex(int [],int);


int main(){
	int n,m;
	cin>>n>>m;
	char p[100][50];
	int inverArr[100]={0}; //得到字符数组p【】【】的逆序数
	for(int i=0;i<m;i++){
		int inver=0;

		for(int j=0;j<n;j++){
			cin>>p[i][j];	
		}
		for(int j=0;j<n;j++){
			for(int k=j+1;k<n;k++)
				if(p[i][j]>p[i][k])
					inver++;
			
		inverArr[i]=inver;
		}
	}
	/*每次找到inverArr【】的一个最小值的下标i,然后把inverArr【i】的值设为一个最大值maxinver,
	之后再次循环找到inverArr【】数组的次小值。。。*/
	for(int i=0;i<m;i++){
		int minIndex = getMinIndex(inverArr,m);
		inverArr[minIndex]= maxinver;

		for(int j=0;j<n;j++)
			cout<<p[minIndex][j];
		cout<<endl;
			
	}

	return 0;
}

/*找到数组inver【】的最小值的下标*/
int getMinIndex(int inver[],int length){
	int min = inver[0];
	int k=0;
	for(int i=1;i<length;i++){
		if(inver[i]<min){
			min = inver[i];
			k = i;
		}
	}
	return k;
}

抱歉!评论已关闭.