现在的位置: 首页 > 综合 > 正文

UVa 558 – Wormholes (求负回路)

2013年08月18日 ⁄ 综合 ⁄ 共 3225字 ⁄ 字号 评论关闭

链接:

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&category=&problem=499&mosmsg=Submission+received+with+ID+10614453

题目:

  Wormholes 


In the year 2163, wormholes were discovered. A wormhole is a subspace tunnel through space and time connecting two star systems. Wormholes have a few peculiar properties:

  • Wormholes are one-way only.

  • The time it takes to travel through a wormhole is negligible.

  • A wormhole has two end points, each situated in a star system.

  • A star system may have more than one wormhole end point within its boundaries.

  • For some unknown reason, starting from our solar system, it is always possible to end up in any star system by following a sequence of wormholes (maybe Earth is the centre of the universe).

  • Between any pair of star systems, there is at most one wormhole in either direction.

  • There are no wormholes with both end points in the same star system.

All wormholes have a constant time difference between their end points. For example, a specific wormhole may cause the person travelling through it to end up 15 years in the future. Another wormhole may
cause the person to end up 42 years in the past.

A brilliant physicist, living on earth, wants to use wormholes to study the Big Bang. Since warp drive has not been invented yet, it is not possible for her to travel from one star system to another one directly. This can be done using wormholes, of
course.

The scientist wants to reach a cycle of wormholes somewhere in the universe that causes her to end up in the past. By travelling along this cycle a lot of times, the scientist is able to go back as far in time as necessary to reach the beginning of the universe
and see the Big Bang with her own eyes. Write a program to find out whether such a cycle exists.

Input 

The input file starts with a line containing the number of cases c to
be analysed. Each case starts with a line with two numbers 
n and m .
These indicate the number of star systems ( 
$1 \le n \le 1000$)
and the number of wormholes (
$0 \le m \le 2000$)
. The star systems are numbered from 0 (our solar system) through 
n-1 . For each wormhole a line containing three integer numbers xy and t is
given. These numbers indicate that this wormhole allows someone to travel from the star system numbered 
x to the star system numbered y,
thereby ending up 
t ( $-1000 \le t \le 1000$)
years in the future.

Output 

The output consists of c lines, one line for each case, containing the
word 
possible if it is indeed possible to go back in time indefinitely, or not possible if this is not possible
with the given set of star systems and wormholes.

Sample Input 

2
3 3
0 1 1000
1 2 15
2 1 -42
4 4
0 1 10
1 2 20
2 3 30
3 0 -60

Sample Output 

possible
not possible

分析与总结:

其实就是寻找一条负数的回环,对于SPFA算法如果一个节点更新了 n 次,那么存在负环;

用一个数组来记录各点的更新次数,一旦有大于等于n的,那么就是有负数回环。

代码:

#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;

const int N = 5005;
const int INF = 1000000000;

int n, m, head[N],next[N],u[N],v[N],w[N],d[N], cnt[N];
bool vis[N];

inline void read_graph(){
    scanf("%d%d",&n,&m);
    memset(head, -1, sizeof(head));
    for(int e=1; e<=m; ++e){
        scanf("%d%d%d",&u[e],&v[e],&w[e]);
        next[e] = head[u[e]];
        head[u[e]] = e;
    }
}

inline bool SPFA(int src){
    memset(vis, 0, sizeof(vis));
    memset(cnt, 0, sizeof(cnt));
    for(int i=0; i<n; ++i) d[i] = INF;
    d[src] = 0;

    ++cnt[src];
    queue<int>q;
    q.push(src);
    while(!q.empty()){
        int u=q.front();  q.pop();
        vis[u] = false;
        for(int e=head[u]; e!=-1; e=next[e]) if(d[v[e]]>d[u]+w[e]){
            d[v[e]] = d[u]+w[e];
            if(!vis[v[e]]){
                q.push(v[e]);
                vis[v[e]] = true;
                if(++cnt[v[e]]>=n) return true;
            }
        }
    }
    return false;
}

int main(){
    int T;
    scanf("%d",&T);
    while(T--){
        read_graph();

        if(SPFA(0)) printf("possible\n");
        else printf("not possible\n");
    }
    return 0;
}

——  生命的意义,在于赋予它意义。

          
     原创 http://blog.csdn.net/shuangde800 , By   D_Double  (转载请标明)

抱歉!评论已关闭.