现在的位置: 首页 > 综合 > 正文

UVa 10340 – All in All

2013年08月15日 ⁄ 综合 ⁄ 共 1555字 ⁄ 字号 评论关闭

链接:

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=113&page=show_problem&problem=1281

原题:

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted
into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.

Input Specification

The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace. Input is terminated by EOF.

Output Specification

For each test case output, if s is a subsequence of t.

Sample Input

sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter

Sample Output

Yes
No
Yes
No

分析与总结:
简单题,直接判断一个字符串是否是另一个字符串的子串。

代码:
/*
 *  UVa: 10340 - All in All
 *  Time: 0.008s
 *  Author: D_Double
 */
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
char str1[1000000], str2[1000000];

bool judge(){
    int pos=0, i;
    for(i=0; i<strlen(str1); ++i){
        bool flag=false;
        while(pos < strlen(str2)){
            if(str2[pos]==str1[i])
                break;
            ++pos;
        }
        if(pos==strlen(str2)) return false;
        ++pos;
    }
    if(i==strlen(str1)) return true;
    return false;
}

int main(){
    while(scanf("%s %s",str1,str2)!=EOF){
        if(judge()) printf("Yes\n");
        else printf("No\n");
    }
    return 0;
}

——  生命的意义,在于赋予它意义。

          
     原创 http://blog.csdn.net/shuangde800 , By   D_Double  (转载请标明)

抱歉!评论已关闭.