现在的位置: 首页 > 综合 > 正文

uva 11054 – Wine trading in Gergovia

2013年08月01日 ⁄ 综合 ⁄ 共 1981字 ⁄ 字号 评论关闭

2006/2007 ACM International Collegiate Programming Contest
University of Ulm Local Contest

Wine trading in Gergovia

As you may know from the comic "Asterix and the Chieftain's Shield", Gergovia consists of one street, and every inhabitant of the city is a wine salesman. You wonder how this economy works? Simple enough: everyone buys wine from other inhabitants of the
city. Every day each inhabitant decides how much wine he wants to buy or sell. Interestingly, demand and supply is always the same, so that each inhabitant gets what he wants.

There is one problem, however: Transporting wine from one house to another results in work. Since all wines are equally good, the inhabitants of Gergovia don't care which persons they are doing trade with, they are only interested in selling or buying a
specific amount of wine. They are clever enough to figure out a way of trading so that the overall amount of work needed for transports is minimized.

In this problem you are asked to reconstruct the trading during one day in Gergovia. For simplicity we will assume that the houses are built along a straight line with equal distance between adjacent houses. Transporting one bottle of wine from one house
to an adjacent house results in one unit of work.

Input Specification

The input consists of several test cases. Each test case starts with the number of inhabitants
n (2 ≤ n ≤ 100000). The following line contains n integers ai (-1000 ≤ ai ≤ 1000). If ai ≥ 0, it means that the inhabitant living in the ith house wants to buy ai bottles of wine, otherwise
if ai < 0, he wants to sell -ai bottles of wine. You may assume that the numbers ai sum up to 0.
The last test case is followed by a line containing 0.

Output Specification

For each test case print the minimum amount of work units needed so that every inhabitant has his demand fulfilled. You may assume that this number fits into a signed 64-bit integer (in C/C++ you can use the data type "long long", in JAVA the data type "long").

Sample Input

5
5 -4 1 -3 1
6
-1000 -1000 -1000 1000 1000 1000
0

Sample Output

9
9000
不知道第几次看到了,学校oj 比赛了出现了很多次了,很明显的按位贪心
#include<stdio.h>
long long a[100010],s,n,i,j;
int main()
{
 while (scanf("%lld",&n),n)
 {
  s=0;
  for (i=1;i<=n;i++)
  scanf("%lld",&a[i]);
  for (i=2;i<=n;i++)
  {
   if (a[i-1]>=0) {s=s+a[i-1]; a[i]+=a[i-1];}
	 else {s=s-a[i-1]; a[i]=a[i]+a[i-1];}
  }
 printf("%lld\n",s);
 }
 return 0;
} 

 

抱歉!评论已关闭.