现在的位置: 首页 > 综合 > 正文

HDU 1800 Flying to the Mars(trie)

2013年09月21日 ⁄ 综合 ⁄ 共 2924字 ⁄ 字号 评论关闭

Flying to the Mars

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8081    Accepted Submission(s): 2618


Problem Description


In the year 8888, the Earth is ruled by the PPF Empire . As the population growing , PPF needs to find more land for the newborns . Finally , PPF decides to attack Kscinow who ruling the Mars . Here the problem comes! How can the soldiers reach the Mars ? PPF
convokes his soldiers and asks for their suggestions . “Rush … ” one soldier answers. “Shut up ! Do I have to remind you that there isn’t any road to the Mars from here!” PPF replies. “Fly !” another answers. PPF smiles :“Clever guy ! Although we haven’t got
wings , I can buy some magic broomsticks from HARRY POTTER to help you .” Now , it’s time to learn to fly on a broomstick ! we assume that one soldier has one level number indicating his degree. The soldier who has a higher level could teach the lower , that
is to say the former’s level > the latter’s . But the lower can’t teach the higher. One soldier can have only one teacher at most , certainly , having no teacher is also legal. Similarly one soldier can have only one student at most while having no student
is also possible. Teacher can teach his student on the same broomstick .Certainly , all the soldier must have practiced on the broomstick before they fly to the Mars! Magic broomstick is expensive !So , can you help PPF to calculate the minimum number of the
broomstick needed .
For example : 
There are 5 soldiers (A B C D E)with level numbers : 2 4 5 6 4;
One method :
C could teach B; B could teach A; So , A B C are eligible to study on the same broomstick.
D could teach E;So D E are eligible to study on the same broomstick;
Using this method , we need 2 broomsticks.
Another method:
D could teach A; So A D are eligible to study on the same broomstick.
C could teach B; So B C are eligible to study on the same broomstick.
E with no teacher or student are eligible to study on one broomstick.
Using the method ,we need 3 broomsticks.
……

After checking up all possible method, we found that 2 is the minimum number of broomsticks needed. 

 


Input
Input file contains multiple test cases. 
In a test case,the first line contains a single positive number N indicating the number of soldiers.(0<=N<=3000)
Next N lines :There is only one nonnegative integer on each line , indicating the level number for each soldier.( less than 30 digits);
 


Output
For each case, output the minimum number of broomsticks on a single line.
 


Sample Input
4 10 20 30 04 5 2 3 4 3 4
 


Sample Output
1 2
 


Author
PPF@JLU
 


Recommend
lcy
 
这个题目如果不是数字比较特殊,可以直接排序就OK 了
这个题目用trie树还是比较有优势的,直接记录每个没有前缀0的串出现的次数,直接在插入的
时候就统计出来了,比较方便,也比较简单!
#include <iostream>
#include <string.h>
#include <stdio.h>
using namespace std;
struct trie
{
trie *next[10];
int num;
}re_root,po[100000];
int pos;
int ans;
int insert(trie *root,char *name)
{
int i=0;
while(name[i])
{
if(root->next[name[i]-'0'])
root=root->next[name[i]-'0'];
else
{
root->next[name[i]-'0']=&po[pos];
memset(po[pos].next,0,sizeof(po[pos].next));
po[pos].num=0;
root=root->next[name[i]-'0'];
pos++;
}
i++;
}
root->num++;
if(ans < root->num)
ans=root->num;
return 0;
}
int n;
char str[100001];
int main()
{
int i,j,k;
while(scanf("%d",&n)!=EOF)
{
pos=0;
ans=0;
memset(re_root.next,0,sizeof(re_root.next));
re_root.num=0;
for(i=0;i<n;i++)
{
scanf("%s",str);
for(j=0; ;j++)
if(str[j]!='0') {insert(&re_root,str+j); break;}
}
printf("%d\n",ans);
}
return 0;
}

抱歉!评论已关闭.