现在的位置: 首页 > 综合 > 正文

[sicily online]1099. Packing Passengers

2013年09月04日 ⁄ 综合 ⁄ 共 3509字 ⁄ 字号 评论关闭

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

PTA, Pack ‘em Tight Airlines is attempting the seemingly impossible—to fly with only full planes and still make a profit. Their strategy is simplicity and efficiency. Their fleet consists of 2 types of equipment (airline lingo for airplanes). Type A aircraft
cost costA dollars to operate per flight and can carry passengersA passengers. Type B aircraft cost costB dollars to operate per flight and can carry passengersB passengers.

PTA has been using software that works well for fewer than 100 passengers, but will be far too slow for the number of passengers they expect to have with larger aircraft. PTA wants you to write a program that fills each aircraft to capacity (in keeping with
the name Pack 'em Tight) and also minimizes the total cost of operations for that route.

Input

The input file may contain data sets. Each data set begins with a line containing the integer n (1 <= n <= 2,000,000,000) which represents the number of passengers for that route. The second line contains costA and passengersA, and the third line contains costB
and passengersB. There will be white space between the pairs of values on each line. Here, costA, passengersA, costB, and passengersB are all nonnegative integers having values less than 2,000,000,001.
After the end of the final data set, there is a line containing “0” (one zero) which should not be processed.

Output

For each data set in the input file, the output file should contain a single line formatted as follows:
Data set <N>: <A> aircraft A, <B> aircraft B
Where <N> is an integer number equal to 1 for the first data set, and incremented by one for each subsequent data set, <A> is the number of airplanes of type A in the optimal solution for the test case, and <B> is the number of airplanes of type B in the optimal
solution. The 'optimal' solution is a solution that lets PTA carry the number of passengers specified in the input for that data set using only airplanes loaded to their full capacity and that minimizes the cost of operating the required flights. If multiple
alternatives exist fitting this description, select the one that uses most airplanes of type A. If no solution exists for PTA to fly the given number of passengers, the out line should be formatted as follows:
Data set <N>: cannot be flown

Sample Input

600
30 20
20 40
550
1 13
2 29
549
1 13
2 29
2000000000
1 2
3 7
599
11 20
22 40
0

Sample Output

Data set 1: 0 aircraft A, 15 aircraft B
Data set 2: 20 aircraft A, 10 aircraft B
Data set 3: 11 aircraft A, 14 aircraft B
Data set 4: 6 aircraft A, 285714284 aircraft B
Data set 5: cannot be flown

题目分析:

ax+by=w,已知a,b,w求x,y且x和y是非负整数。但是x和y有一个权值,所有x和y中找费用最小的,假设x的费用比较小,所以取x的更大值,y的更小值,只需要遍历即可(注意乘客数为0的情况)

#include<iostream>
#include <iomanip>
#include<stdio.h>
#include<cmath>
#include<iomanip>
#include<list>
#include <map>
#include <vector>
#include <string>
#include <algorithm>
#include <sstream>
#include <stack>
#include<queue>
#include<string.h>
using namespace std;


int main()
{
	long long n;
	int geshu=0;
	while(scanf("%lld",&n)&&n!=0)
	{
		geshu++;
		unsigned int costA,costB,passengersA,passengersB;
		scanf("%d%d%d%d",&costA,&passengersA,&costB,&passengersB);
		double biA=(double)costA/passengersA,biB=(double)costB/passengersB;
		bool chgFlag=false;
		if(biA>biB)
		{
			chgFlag=true;
			swap(costA,costB);
			swap(passengersA,passengersB);
		}
		unsigned int count=0,numberB=0,numberA;
		bool flag=false;
		unsigned long long cost=-1;
		while(1)
		{
			if(n<0)
				break;
			if(passengersA==0&&passengersB==0)
				break;
			else if(passengersA==0)
			{
				if(n%passengersB==0)
				{
					flag=true;
					numberA=0;
					numberB=n/passengersB;
				}
				break;
			}
			else if(passengersB==0)
			{
				if(n%passengersA==0)
				{
					flag=true;
					numberB=0;
					numberA=n/passengersA;
				}
				break;
			}
			if(n%passengersA==0)
			{
				unsigned long long price=n/passengersA*costA+count*costB;
				if(price<cost)
				{
					flag=true;
					cost=price;
					numberA=n/passengersA;
					numberB=count;
					break;
				}
			}
			count++;
			n=n-passengersB;
		}
		printf("Data set %d: ",geshu);
		if(chgFlag)
			swap(numberA,numberB);
		if(flag)
			printf("%d aircraft A, %d aircraft B\n",numberA,numberB);
		else printf("cannot be flown\n");
	}
}
【上篇】
【下篇】

抱歉!评论已关闭.