现在的位置: 首页 > 综合 > 正文

hdu4442

2013年09月07日 ⁄ 综合 ⁄ 共 2513字 ⁄ 字号 评论关闭

Physical Examination

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3428    Accepted Submission(s): 939


Problem Description
WANGPENG is a freshman. He is requested to have a physical examination when entering the university.
Now WANGPENG arrives at the hospital. Er….. There are so many students, and the number is increasing!
There are many examination subjects to do, and there is a queue for every subject. The queues are getting longer as time goes by. Choosing the queue to stand is always a problem. Please help WANGPENG to determine an exam sequence, so that he can finish all
the physical examination subjects as early as possible.
 


Input
There are several test cases. Each test case starts with a positive integer n in a line, meaning the number of subjects(queues).
Then n lines follow. The i-th line has a pair of integers (ai, bi) to describe the i-th queue:
1. If WANGPENG follows this queue at time 0, WANGPENG has to wait for ai seconds to finish this subject.
2. As the queue is getting longer, the waiting time will increase bi seconds every second while WANGPENG is not in the queue.
The input ends with n = 0.
For all test cases, 0<n≤100000, 0≤ai,bi<231.
 


Output
For each test case, output one line with an integer: the earliest time (counted by seconds) that WANGPENG can finish all exam subjects. Since WANGPENG is always confused by years, just print the seconds mod 365×24×60×60.
 


Sample Input
5 1 2 2 3 3 4 4 5 5 6 0
 


Sample Output
1419
Hint
In the Sample Input, WANGPENG just follow the given order. He spends 1 second in the first queue, 5 seconds in the 2th queue, 27 seconds in the 3th queue, 169 seconds in the 4th queue, and 1217 seconds in the 5th queue. So the total time is 1419s. WANGPENG has computed all possible orders in his 120-core-parallel head, and decided that this is the optimal choice.
 


Source
 


Recommend
zhuyuanchen520
这题坑啊,要用贪心排一下序,要注意的就是,必须要在排序后才能取模,先取模还不行!
#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <string.h>
#define MAXN 100005
using namespace std;
struct node {
    int x,y;
    double yx;
}prime[MAXN];
int mod;
int getint()
{
    char c;
    int sum;
    while(c=getchar())
    {
        if(c<='9'&&c>='0')
        {
            sum=c-'0';
            break;
        }
    }
    while(c=getchar())
    {

        if(c>'9'||c<'0')
        {

            break;
        }
        sum=sum*10+c-'0';
    }

    return sum;
}
bool cmp(node a,node b)
{
    return a.yx<b.yx;
}
int main()
{
    int n,i,nn;
    __int64 sum,sum2;
    mod=365*24*60*60;
    //printf("%d",getint());
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0)
        break;
        sum=0;sum2=0;
        for(i=0,nn=0;i<n;i++,nn++)
        {
            //scanf("%d%d",&prime[i].x,&prime[i].y);
            prime[nn].x=getint();
            prime[nn].y=getint();
            if(prime[nn].y==0)
            {
                sum2+=prime[nn].x;
                nn--;
                continue;
            }
            prime[nn].yx=prime[nn].x*1.0/prime[nn].y;
        }
        sort(prime,prime+nn,cmp);
        for(i=0;i<n;i++)
        {
            sum+=sum*prime[i].y;
            sum=sum%mod;
           sum+=prime[i].x;
           // printf("%d\n",sum);
           sum=sum%mod;
        }
        sum+=sum2;

        printf("%I64d\n",sum%mod);

    }
    return 0;
}

抱歉!评论已关闭.