现在的位置: 首页 > 综合 > 正文

hdu4450

2013年09月07日 ⁄ 综合 ⁄ 共 997字 ⁄ 字号 评论关闭

Draw Something

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1549    Accepted Submission(s): 1294


Problem Description
Wangpeng is good at drawing. Now he wants to say numbers like “521” to his girlfriend through the game draw something.
Wangpeng can’t write the digit directly. So he comes up a way that drawing several squares and the total area of squares is the number he wants to say.
Input all the square Wangpeng draws, what’s the number in the picture?
 


Input
There are multiple test cases.
For each case, the first line contains one integer N(1≤N≤100) indicating the number of squares.
Second line contains N integers ai(1≤ai≤100)represent the side length of each square. No squares will overlap.
Input ends with N = 0.
 


Output
For each case, output the total area in one line.
 


Sample Input
4 1 2 3 4 3 3 3 3 0
 


Sample Output
30 27
 


Source
 


Recommend
zhuyuanchen520
#include <iostream>
#include <stdio.h>
using namespace std;

int main()
{
    int n,temp,sum;
    while(scanf("%d",&n)!=EOF&&n)
    {
        sum=0;
        while(n--)
        {
            scanf("%d",&temp);
            sum+=temp*temp;
        }
        printf("%d\n",sum);
    }
    return 0;
}

抱歉!评论已关闭.