现在的位置: 首页 > 综合 > 正文

hdu4331 Image Recognition

2013年09月02日 ⁄ 综合 ⁄ 共 1603字 ⁄ 字号 评论关闭

Image Recognition

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 964    Accepted Submission(s): 371


Problem Description
Now there is an image recognition problem for you. Now you are given an image which is a N * N matrix and there are only 0s and 1s in the matrix. And we are interested in the squares in whose four edges there is no 0s. So it’s your task to find how many such
squares in the image.
 


Input
The first line of the input contains an integer T (1<=T<=10) which means the number of test cases. 
For each test cases, the first line is one integer N (1<=N<=1000) which is the size of the image. Then there are N lines and each line has N integers each of which is either 0 or 1.
 


Output
For each test case, please output a line which is "Case X: Y", X means the number of the test case and Y means the number of the squares we are interested in in the image.
 


Sample Input
1 3 1 1 0 1 1 0 0 0 0
 


Sample Output
Case 1: 5
 


Source
 


Recommend
zhoujiaqi2010
正归的做法应该是线段树,没想到用暴力过了,呵呵
#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
#define MAXN 1005
int up[MAXN][MAXN];
int lleft[MAXN][MAXN];
int map[MAXN][MAXN];
int fmin(int a,int b)
{
    if(a<b)
    return a;
    return b;
}
int main()
{
    int n,tcase,i,j,t=1;
    int ans;
    scanf("%d",&tcase);
    while(tcase--)
    {
        scanf("%d",&n);
        ans=0;
        memset(lleft,0,sizeof(lleft));
        memset(up,0,sizeof(up));
        for(i=1;i<=n;i++)
            for(j=1;j<=n;j++)
            {
                scanf("%d",&map[i][j]);
                if(map[i][j])
                {
                    ans++;
                    lleft[i][j]=lleft[i][j-1]+1;
                    up[i][j]=up[i-1][j]+1;
                }
                else
                {
                    lleft[i][j]=0;
                    up[i][j]=0;
                }
            }
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=n;j++)
            {
              
                int k=fmin(up[i][j],lleft[i][j]);
                if(k<=1)
                continue;
                int temp;
                for(temp=2;temp<=k;temp++)
                {
                    if(up[i][j-temp+1]>=temp&&lleft[i-temp+1][j]>=temp)
                    {
                        ans++;
                   
                    }
                }

            }
          
        }

        printf("Case %d: %d\n",t++,ans);
    }

    return 0;
}

抱歉!评论已关闭.