现在的位置: 首页 > 综合 > 正文

poj 1273 Drainage Ditches—maxflow最大流

2013年09月22日 ⁄ 综合 ⁄ 共 2344字 ⁄ 字号 评论关闭

Description

Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's
clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch. 
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network. 
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle. 

Input

The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points
for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow
through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.

Output

For each case, output a single integer, the maximum rate at which water may emptied from the pond.

Sample Input

5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10

Sample Output

50
典型的网络最大流算法,才用ek算法。注意有重边,边是有方向的。
#include <cstdio>
#include <cstring>
#include <iostream>
#include <queue>
#include <fstream>
using namespace std;

const int nmax=202;
long long c[nmax][nmax];
int vis[nmax],pre[nmax];
int n,m;
bool Augmenting_Path(int src,int dec)
{
	queue<int> q;
	memset(vis,0,sizeof(vis));
	q.push(src);
	vis[src]=1;
	while(!q.empty())
	{
		int cur=q.front();
		q.pop();
		for(int i=1;i<=m;i++)
		{
			if(!vis[i]&&c[cur][i]>0)
			{
				q.push(i);
				vis[i]=1;
				pre[i]=cur;
				if(i==dec)return 1;
			}
		}
	}
	return 0;
	
}
int ek(int src,int dec)
{
	int flow=0,_min;
	while(1)
	{
		if(!Augmenting_Path(src,dec))break;
		_min=1<<30;
		int i=dec;
		while(i!=src){
			if(_min>c[pre[i]][i])_min=c[pre[i]][i];
			i=pre[i];
		}
		i=dec;
		while(i!=src)
		{
			c[pre[i]][i] -= _min;
            c[i][pre[i]] += _min;
            i = pre[i];
		}
		flow+=_min;
	}
	return flow;
}
int main()
{
	while(cin>>n>>m)
	{
		int si,ei;
		long long ci;
		memset(c,0,sizeof(c));
		for(int i=0;i<n;i++)
		{
			cin>>si>>ei>>ci;
			c[si][ei]+=ci;
			//c[ei][si]+=ci;  //边有方向 
		}
		int src=1,dec=m;
		cout<<ek(src,dec)<<endl;
	}
	return 0;
}

抱歉!评论已关闭.