现在的位置: 首页 > 综合 > 正文

HDU1035 Prime Ring Problem

2013年09月09日 ⁄ 综合 ⁄ 共 1480字 ⁄ 字号 评论关闭
文章目录

                                                   Prime Ring Problem

Time Limit : 4000/2000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 14   Accepted Submission(s) : 10

Font: Times New Roman | Verdana | Georgia

Font Size:

Problem Description

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

Input

n (0 < n < 20).

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical
order.

You are to write a program that completes above process.

Print a blank line after each case.

Sample Input

6
8

Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

Source

Asia 1996, Shanghai (Mainland China)

解题思路:本题为典型一维深度优先搜索题。我学深搜时模仿的第一个代码,不知道怎么码解说了。。。。。。

#include<cstdio>
#include<cstring>
using namespace std;
int n;
int cil[22];    //已使用数据的存储
int num[22]; //数据使用情况0,1
int prime[40]={0,0,1,1,0,1,0,1,0,0,0,1,0,1,0,0,0,1,0,1,0,0,0,1,0,0,0,0,0,1,0,1,0,0,0,0,0,1,0,0};   // 素数列表,hass表
void dfs(int x)
{
    int i,j;
    if(x==n&&prime[cil[0]+cil[x-1]])    //环已满,头尾能连接,符合要求
    {
        printf("1");
        for(i=1;i<n;i++)
            printf(" %d",cil[i]);
        printf("\n");
    }
    else
    {
        for(i=2;i<=n;i++)
        {
            if(!num[i]&&prime[cil[x-1]+i])
            {
                cil[x]=i;
                num[i]=1;
                dfs(x+1);
                num[i]=0;
            }
        }
    }
}
int main()
{
    int i=1;
    while(scanf("%d",&n)!=EOF)
    {
        memset(num,0,sizeof(num));
        cil[0]=1;
        printf("Case %d:\n",i++);
        dfs(1);
        printf("\n");
    }
    return 0;
}

抱歉!评论已关闭.