现在的位置: 首页 > 综合 > 正文

ACM练习 题目1029:魔咒词典 C++ map的使用

2013年09月10日 ⁄ 综合 ⁄ 共 2264字 ⁄ 字号 评论关闭
题目描述:
    哈利波特在魔法学校的必修课之一就是学习魔咒。据说魔法世界有100000种不同的魔咒,哈利很难全部记住,但是为了对抗强敌,他必须在危急时刻能够调用任何一个需要的魔咒,所以他需要你的帮助。

    给你一部魔咒词典。当哈利听到一个魔咒时,你的程序必须告诉他那个魔咒的功能;当哈利需要某个功能但不知道该用什么魔咒时,你的程序要替他找到相应的魔咒。如果他要的魔咒不在词典中,就输出“what?”

输入:

    首先列出词典中不超过100000条不同的魔咒词条,每条格式为:

    [魔咒] 对应功能

    其中“魔咒”和“对应功能”分别为长度不超过20和80的字符串,字符串中保证不包含字符“[”和“]”,且“]”和后面的字符串之间有且仅有一个空格。词典最后一行以“@END@”结束,这一行不属于词典中的词条。
    词典之后的一行包含正整数N(<=1000),随后是N个测试用例。每个测试用例占一行,或者给出“[魔咒]”,或者给出“对应功能”。

输出:
    每个测试用例的输出占一行,输出魔咒对应的功能,或者功能对应的魔咒。如果魔咒不在词典中,就输出“what?”
样例输入:
[expelliarmus] the disarming charm
[rictusempra] send a jet of silver light to hit the enemy
[tarantallegra] control the movement of one's legs
[serpensortia] shoot a snake out of the end of one's wand
[lumos] light the wand
[obliviate] the memory charm
[expecto patronum] send a Patronus to the dementors
[accio] the summoning charm
@END@
4
[lumos]
the summoning charm
[arha]
take me to the sky
样例输出:
light the wand
accio
what?
what?


思路很简单,就是用map保存,再拿出来。

还是不太会用C++,C++的map存放char * 貌似是不行的,自定义的比较函数也不起作用。还望高手指点~

输入输出做的也有点别扭~委屈

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <map>
using namespace std;

//class StrCompare{
//public:
//    bool operator() (const char* str1, const char* str2) const
//    { return strcmp(str1, str2) < 0; }
//};

//map<char *,char *,StrCompare> map1;
//map<char *,char *,StrCompare> map2;

map<string, string> map1; //保存<魔咒,对应功能>
map<string, string> map2; //保存<对应功能,魔咒>
int main() {
	char first;
	scanf("%c", &first);
	while (first == '[') {
		char temp[100]; //用临时变量保存剩下的整行
		gets(temp);
		char * text = strchr(temp, ']'); //找到 ] 的位置
		int len = strlen(temp) - strlen(text);
		text += 2; //得到后半部分的 char *
		string value(text);

		//char value[80];
		//strcpy(value, text);
		temp[len] = '\0';
		string key(temp);
//		char tempKey[20];
//		char tempStr[80];
//		scanf("%s",tempKey);
//		tempKey[strlen(tempKey)-1] = '\0';
//		scanf(" ");
//		gets(tempStr);
//		cout << temp << endl;
//		cout << value << endl;

//		map1.insert(pair<char *,char *>(temp,value));
//		map2.insert(pair<char *,char *>(value,temp));
		map1.insert(pair<string, string>(key, value));
		map2.insert(pair<string, string>(value, key));
		scanf("%c", &first);
	}
	char aaaa[10];
	gets(aaaa); //把剩余的读取了
	int n;
	scanf("%d\n", &n);
	map<string, string>::iterator it;
	for (int i = 0; i < n; i++) {
		string str;
		getline(cin, str);
		if (str.at(0) == '[') {
			str = str.substr(1, str.length() - 2);
			it = map1.find(str);
			if (it != map1.end())
				cout << it->second << endl;
			else
				cout << "what?" << endl;
		} else {
			it = map2.find(str);
			if (it != map2.end())
				cout << it->second << endl;
			else
				cout << "what?" << endl;
		}
	}

	return 0;
}

抱歉!评论已关闭.