现在的位置: 首页 > 综合 > 正文

hdu 1078 FatMouse and Cheese (记忆化搜索 )

2013年10月13日 ⁄ 综合 ⁄ 共 2178字 ⁄ 字号 评论关闭

FatMouse and Cheese

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 3509    Accepted Submission(s): 1388
Problem Description
FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100
blocks of cheese in a hole. Now he's going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run
at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks
of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.

 

Input
There are several test cases. Each test case consists of

a line containing two integers between 1 and 100: n and k
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on.

The input ends with a pair of -1's.

 

Output
For each test case output in a line the single integer giving the number of blocks of cheese collected.
 

Sample Input
3 1 1 2 5 10 11 6 12 12 7 -1 -1
 

Sample Output
37
 
题意:老鼠偷吃,有n*n的方阵,每个格子里面放着一定数目的粮食,老鼠每次只能水平或竖直最多走k步,每次必须走食物比当前多的格子,问最多吃多少食物。
ps:英语好烂  题意都读不懂 

思路:记忆化搜索   和那道滑雪差不多 就是多个循环就够了  因为可以走k步
#include <iostream>
#include <cstdio>
#include <cstring>
#define maxn 105
using namespace std;

int n,m,k,ans;
int mp[maxn][maxn];
int dp[maxn][maxn];
int dx[]= {-1,1,0,0};
int dy[]= {0,0,-1,1};

int dfs(int x,int y)
{
    if(dp[x][y]) return dp[x][y];   // 已经搜过 就不用再搜了
    int i,j,t,tx,ty,ma=0;
    for(i=1; i<=k; i++)
    {
        for(j=0; j<4; j++)
        {
            tx=x+i*dx[j];
            ty=y+i*dy[j];
            if(tx>=1&&tx<=n&&ty>=1&&ty<=n&&mp[tx][ty]>mp[x][y])
            {
                t=dfs(tx,ty);
                if(ma<t) ma=t;
            }
        }
    }
    dp[x][y]=ma+mp[x][y];
    return dp[x][y];
}
int main()
{
    int i,j,t;
    while(scanf("%d%d",&n,&k))
    {
        if(n==-1&&k==-1) break ;
        memset(dp,0,sizeof(dp));
        for(i=1; i<=n; i++)
        {
            for(j=1; j<=n; j++)
            {
                scanf("%d",&mp[i][j]);
            }
        }
        printf("%d\n",dfs(1,1));
    }
    return 0;
}

 

抱歉!评论已关闭.