现在的位置: 首页 > 综合 > 正文

HDU2952:Counting Sheep(BFS)

2013年10月13日 ⁄ 综合 ⁄ 共 2078字 ⁄ 字号 评论关闭
Problem Description
A while ago I had trouble sleeping. I used to lie awake, staring at the ceiling, for hours and hours. Then one day my grandmother suggested I tried counting sheep after I'd gone to bed. As always when my grandmother suggests
things, I decided to try it out. The only problem was, there were no sheep around to be counted when I went to bed.

Creative as I am, that wasn't going to stop me. I sat down and wrote a computer program that made a grid of characters, where # represents a sheep, while . is grass (or whatever you like, just not sheep). To make the counting a little more interesting, I also
decided I wanted to count flocks of sheep instead of single sheep. Two sheep are in the same flock if they share a common side (up, down, right or left). Also, if sheep A is in the same flock as sheep B, and sheep B is in the same flock as sheep C, then sheeps
A and C are in the same flock.

Now, I've got a new problem. Though counting these sheep actually helps me fall asleep, I find that it is extremely boring. To solve this, I've decided I need another computer program that does the counting for me. Then I'll be able to just start both these
programs before I go to bed, and I'll sleep tight until the morning without any disturbances. I need you to write this program for me.

 


Input
The first line of input contains a single number T, the number of test cases to follow.

Each test case begins with a line containing two numbers, H and W, the height and width of the sheep grid. Then follows H lines, each containing W characters (either # or .), describing that part of the grid.

 


Output
For each test case, output a line containing a single number, the amount of sheep flock son that grid according to the rules stated in the problem description.

Notes and Constraints
0 < T <= 100
0 < H,W <= 100

 


Sample Input
2 4 4 #.#. .#.# #.## .#.# 3 5 ###.# ..#.. #.###
 


Sample Output
6 3
 

前几天用DFS做了一次

现在用BFS再做一次

原理就是已找到#就+1,然后把#附件连通的#全部变成“.”

#include <stdio.h>
#include <string.h>

char map[105][105];
int to[4][2] = {1,0,-1,0,0,1,0,-1};
int n,m,cnt;

void bfs(int x,int y)
{
    int i;
    int xx,yy;
    for(i = 0;i<4;i++)
    {
        xx = x+to[i][0];
        yy = y+to[i][1];
        if(xx<0 || yy<0 || xx>=n || yy>=m || map[xx][yy]!='#')
        continue;
        map[xx][yy] = '.';
        bfs(xx,yy);
    }
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        int i,j,l;
        cnt = 0;
        for(i = 0;i<n;i++)
        {
            scanf("%s",map[i]);
        }
        for(i = 0;i<n;i++)
        {
            for(j = 0;j<m;j++)
            {
                if(map[i][j] == '#')
                {
                    cnt++;
                    map[i][j] = '.';
                    bfs(i,j);
                }
            }
        }
        printf("%d\n",cnt);
    }

    return 0;
}

 

 

抱歉!评论已关闭.