现在的位置: 首页 > 综合 > 正文

HDU2734:Quicksum

2013年10月14日 ⁄ 综合 ⁄ 共 1545字 ⁄ 字号 评论关闭
Problem Description
A checksum is an algorithm that scans a packet of data and returns a single number. The idea is that if the packet is changed, the checksum will also change, so checksums are often used for detecting transmission errors, validating
document contents, and in many other situations where it is necessary to detect undesirable changes in data.

For this problem, you will implement a checksum algorithm called Quicksum. A Quicksum packet allows only uppercase letters and spaces. It always begins and ends with an uppercase letter. Otherwise, spaces and letters can occur in any combination, including
consecutive spaces.

A Quicksum is the sum of the products of each character's position in the packet times the character's value. A space has a value of zero, while letters have a value equal to their position in the alphabet. So, A=1, B=2, etc., through Z=26. Here are example
Quicksum calculations for the packets "ACM" and "MID CENTRAL":

ACM: 1*1 + 2*3 + 3*13 = 46MID CENTRAL: 1*13 + 2*9 + 3*4 + 4*0 + 5*3 + 6*5 + 7*14 + 8*20 + 9*18 + 10*1 + 11*12 = 650

 

Input
The input consists of one or more packets followed by a line containing only # that signals the end of the input. Each packet is on a line by itself, does not begin or end with a space, and contains from 1 to 255 characters.
 

Output
For each packet, output its Quicksum on a separate line in the output.

 

Sample Input
ACM MID CENTRAL REGIONAL PROGRAMMING CONTEST ACN A C M ABC BBC #
 

Sample Output
46 650 4690 49 75 14 15
 

 

 

大水题,不说了,直接代码

 

#include <string.h>
#include <stdio.h>

int main()
{
    char str[10000];
    int len,i,a[26],sum;
    for(i = 0;i<26;i++)//数组存字母
    {
        a[i] = i+1;
    }
    while(gets(str))
    {
        if(strcmp(str,"#") == 0)//是#号就结束
        break;
        len = strlen(str);
        sum = 0;
        for(i = 0;i<len;i++)
        {
            if(str[i]>='A' && str[i]<='Z')
            sum+=(i+1)*a[str[i]-'A'];//算总和
        }
        printf("%d\n",sum);
    }

    return 0;
}


 

抱歉!评论已关闭.