现在的位置: 首页 > 综合 > 正文

HDU2700:Parity

2013年10月14日 ⁄ 综合 ⁄ 共 1116字 ⁄ 字号 评论关闭
Problem Description
A bit string has odd parity if the number of 1's is odd. A bit string has even parity if the number of 1's is even.Zero is considered to be an even number, so a bit string with no 1's has even parity. Note that the number of
0's does not affect the parity of a bit string.
 

Input
The input consists of one or more strings, each on a line by itself, followed by a line containing only "#" that signals the end of the input. Each string contains 1–31 bits followed by either a lowercase letter 'e' or a lowercase
letter 'o'.
 

Output
Each line of output must look just like the corresponding line of input, except that the letter at the end is replaced by the correct bit so that the entire bit string has even parity (if the letter was 'e') or odd parity (if the
letter was 'o').
 

Sample Input
101e 010010o 1e 000e 110100101o #
 

Sample Output
1010 0100101 11 0000 1101001010
 

 

 

//水题,就是以e结尾就把1不成偶数,以o结尾则补成奇数

 

#include <stdio.h>
#include <string.h>

int main()
{
    char str[10000];
    int len,i,cnt;

    while(gets(str))
    {
        cnt = 0;
        if(!strcmp(str,"#"))
        break;
        len = strlen(str);
        for(i = 0;i<len;i++)
        {
            if(str[i] == '1')
            cnt++;
        }
        if(str[len-1] == 'e')
        {
            if(cnt%2 == 0)
            str[len-1] = '0';
            else
            str[len-1] = '1';
        }
        else if(str[len-1] == 'o')
        {
            if(cnt%2 == 0)
            str[len-1] = '1';
            else
            str[len-1] = '0';
        }
        str[len] = '\0';
        printf("%s\n",str);
    }

    return 0;
}

 

抱歉!评论已关闭.