现在的位置: 首页 > 综合 > 正文

POJ2305:Basic remains

2013年10月14日 ⁄ 综合 ⁄ 共 905字 ⁄ 字号 评论关闭

Description

Given a base b and two non-negative base b integers p and m, compute p mod m and print the result as a base b integer. p mod m is defined as the smallest non-negative integer k such that p = a*m + k for some integer a.

Input

Input consists of a number of cases. Each case is represented by a line containing three unsigned integers. The first, b, is a decimal number between 2 and 10. The second, p, contains up to 1000 digits between 0 and b-1. The third,
m, contains up to 9 digits between 0 and b-1. The last case is followed by a line containing 0.

Output

For each test case, print a line giving p mod m as a base-b integer.

Sample Input

2 1100 101
10 123456789123456789123456789 1000
0

Sample Output

10
789
 
 
#include <stdio.h>
#include <stdlib.h>
#include <string.h>

void print(int r,int b)
{
    if(r>0)
    {
        print(r/b,b);
        printf("%d",r%b);
    }
}
int main()
{
    char p[10000],M[10];
    int n,i,m,r;
    while(~scanf("%d",&n))
    {
        if(!n)
            return 0;
        scanf("%s%s",p,M);
        int len = strlen(p);
        m = strtol(M,0,n);
        r = 0;
        for(i = 0; i<len; i++)
        {
            r = r*n+p[i]%48;
            r%=m;
        }
        print(r,n);
        puts(r?"":"0");
    }

    return 0;
}

抱歉!评论已关闭.