现在的位置: 首页 > 综合 > 正文

hdu Leftmost Digit

2013年10月09日 ⁄ 综合 ⁄ 共 836字 ⁄ 字号 评论关闭

思路:刚开始做,发现很纠结!!

后来,看到了一个人的分析,是这样转换的

m=n^n;两边同取对数,得到,log10(m)=n*log10(n);再得到,m=10^(n*log10(n));

然后,对于10的整数次幂,第一位是1,所以,第一位数取决于n*log10(n)的小数部分

总之,log很强大啊,在求一个数的位数上,在将大整数化成范围内的整数上,在指数问题上
    

Problem Description

Given a positive integer N, you should output the leftmost digit of N^N.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).

Output

For each test case, you should output the leftmost digit of N^N.

Sample Input

2
3
4

Sample Output

2
2

Hint

In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2.
In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.
 
代码:
#include<iostream>
#include<cmath>
using namespace std;
int main()
{
    __int64 i,t,a,sum;
    double s,x,n;
    cin>>t;
    while(t--)
    {
      cin>>n;
      s=n*log10(n);
      a=(__int64)s;
      x=s-a;
      sum=(__int64)pow(10.0,x);
      cout<<sum<<endl;
    }
    return 0;
}

抱歉!评论已关闭.