现在的位置: 首页 > 综合 > 正文

POJ 2352 线段树

2013年10月24日 ⁄ 综合 ⁄ 共 2423字 ⁄ 字号 评论关闭

     题意就是让求在某个点左面的星星的个数。因为y是按升序输入的,所以只需要考虑x即可。此题可以用树状数组做,也可以用线段树做。以前用树状数组做过一次,这次用线段树又做了一下。相比来说,树状数组是比较容易想的,而且也更简单。

  用线段树的话,当输入一个点的横坐标x后,考虑位于x左边的点有几个即可。题目:

Stars
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 20676   Accepted: 9015

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know
the distribution of the levels of the stars. 


For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level
0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars
are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

ac代码:

#include <iostream>
#include <cstdio>
#include <string.h>
using namespace std;
const int M=32010;
const int N=15010;
struct tree{
	int left,right,num;
}tt[M*4];
void built_tree(int lp,int rp,int pos){
	tt[pos].left=lp;
	tt[pos].right=rp;
	tt[pos].num=0;
	if(lp==rp)return;
	int mid=(tt[pos].left+tt[pos].right)/2;
	built_tree(lp,mid,pos*2);
	built_tree(mid+1,rp,pos*2+1);
}
int find(int lp,int rp,int pos){
	int sum=0;
	if(tt[pos].left==lp&&tt[pos].right==rp){
		return tt[pos].num;
	}
	else{
	   int mid=(tt[pos].left+tt[pos].right)/2;
	  if(lp>mid){
	    sum+=(find(lp,rp,2*pos+1));
	   }
	   else if(rp<=mid){
	     sum+=(find(lp,rp,2*pos));
	   }
	   else
		  sum+=(find(lp,mid,2*pos)+find(mid+1,rp,2*pos+1));
	   return sum;
	}
}
void add(int x,int pos){
	tt[pos].num++;
	if(tt[pos].left==tt[pos].right&&tt[pos].right==x){
		return;
	}
	int mid=(tt[pos].left+tt[pos].right)/2;
	if(x<=mid)
		add(x,2*pos);
	else
		add(x,2*pos+1);
}
int main(){
	//freopen("1.txt","r",stdin);
	int n;
	while(~scanf("%d",&n)){
	  built_tree(0,M,1);
	  int x,y,ans[N];
	  memset(ans,0,sizeof(ans));
	  for(int i=1;i<=n;++i){
	    scanf("%d%d",&x,&y);
		ans[find(0,x,1)]++;
		add(x,1);
	  }
	  for(int i=0;i<n;++i)
		  printf("%d\n",ans[i]);
	}
	return 0;
}

抱歉!评论已关闭.