现在的位置: 首页 > 综合 > 正文

POJ 3096 Surprising Strings

2013年10月29日 ⁄ 综合 ⁄ 共 1841字 ⁄ 字号 评论关闭

中级的水题,map就可以水过、、主要是练习一下map的使用。

题意就是:判断间隔长度相同的连续的两个字符串是否相同,如果不相同就输出is NOT surprising.否则输出is surprising.

Surprising Strings
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 5315   Accepted: 3492

Description

The D-pairs of a string of letters are the ordered pairs of letters that are distance D from each other. A string is D-unique if all of its D-pairs are different. A string is surprisingif it is D-unique for every possible
distance D.

Consider the string ZGBG. Its 0-pairs are ZG, GB, and BG. Since these three pairs are all different, ZGBG is 0-unique. Similarly, the 1-pairs of ZGBG are ZB and GG, and since these two pairs are different, ZGBG is 1-unique. Finally, the only 2-pair of ZGBG
is ZG, so ZGBG is 2-unique. Thus ZGBG is surprising. (Note that the fact that ZG is both a 0-pair and a 2-pair of ZGBG is irrelevant, because 0 and 2 are different distances.)

Acknowledgement: This problem is inspired by the "Puzzling Adventures" column in the December 2003 issue of Scientific American.

Input

The input consists of one or more nonempty strings of at most 79 uppercase letters, each string on a line by itself, followed by a line containing only an asterisk that signals the end of the input.

Output

For each string of letters, output whether or not it is surprising using the exact output format shown below.

Sample Input

ZGBG
X
EE
AAB
AABA
AABB
BCBABCC
*

Sample Output

ZGBG is surprising.
X is surprising.
EE is surprising.
AAB is surprising.
AABA is surprising.
AABB is NOT surprising.
BCBABCC is NOT surprising.
#include <iostream>
#include <stdlib.h>
#include <stdio.h>
#include <string>
#include <cmath>
#include <string.h>
#include <map>

using namespace std;

char s[110];
int main()
{
    int i, j, k;
    while(cin >>s)
    {
        k = strlen(s);
        if(k == 1 && s[0] == '*')
            break;
        if(k <= 2)
        {
            cout <<s<<" is surprising."<<endl;
            continue;
        }
        int flag = 1;
        for(i = 0; i <= k-2; i++)
        {
            map<string , bool> flat;
            int flag1 = 1;
            for(j = 0; j <= k-2-i; j++)
            {
                char str[3]= {s[j], s[j+i+1], '\0'};
                if(!flat[str])
                    flat[str] = true;
                else
                {
                    flag1 = 0;
                    break;
                }
            }
            if(!flag1)
            {
                flag = 0;
                break;
            }
        }
        if(!flag)
            cout <<s<<" is NOT surprising."<<endl;
        else
            cout <<s<<" is surprising."<<endl;
    }
    return 0;
}

抱歉!评论已关闭.