现在的位置: 首页 > 综合 > 正文

poj 1442 Black Box

2013年10月06日 ⁄ 综合 ⁄ 共 2945字 ⁄ 字号 评论关闭

这道题的题意是输入n,m。n次操作代表向数列中插入数据,m次操作代表输出在此时的数列长度下,数列中第Mi小的数据;

就是题意中的图,解释的:

1 ADD(3)      0 3   

2 GET         1 3                                    3 

3 ADD(1)      1 1, 3   

4 GET         2 1, 3                                 3 

5 ADD(-4)     2 -4, 1, 3   

6 ADD(2)      2 -4, 1, 2, 3   

7 ADD(8)      2 -4, 1, 2, 3, 8   

8 ADD(-1000)  2 -1000, -4, 1, 2, 3, 8   

9 GET         3 -1000, -4, 1, 2, 3, 8                1 

10 GET        4 -1000, -4, 1, 2, 3, 8                2 

11 ADD(2)     4 -1000, -4, 1, 2, 2, 3, 8   

解题思路是:

用两个堆来实现,一个最大对和一个最小堆,下面解释下这两个堆的作用。

首先:一个最大堆存放的目前已经经过k步ADD的到的序列中前i-1大的值,而最小堆存放的是从第i大道第k大的值。

其实我们只要在最小堆中找到一个最小的值,就一定是第i大的值,因为最大堆中的任何一个数都要比最小堆中的元素都要小

当然我们找到第i大的值后要将其并到最大堆中,而且在想最小堆中加入数据时要比较其值是否比最大堆中所有的值都要大,如果不

是大于的话,则要将其与最大堆中最大的元素交换。否则得到的最大堆不会比最小堆中任何的元素小了。

Black Box
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 5897   Accepted: 2374

Description

Our Black Box represents a primitive database. It can save an integer array and has a special i variable. At the initial moment Black Box is empty and i equals 0. This Black Box processes a sequence of commands (transactions). There are two types of transactions: 

ADD (x): put element x into Black Box; 
GET: increase i by 1 and give an i-minimum out of all integers containing in the Black Box. Keep in mind that i-minimum is a number located at i-th place after Black Box elements sorting by non- descending. 

Let us examine a possible sequence of 11 transactions: 

Example 1 

N Transaction i Black Box contents after transaction Answer 

      (elements are arranged by non-descending)   

1 ADD(3)      0 3   

2 GET         1 3                                    3 

3 ADD(1)      1 1, 3   

4 GET         2 1, 3                                 3 

5 ADD(-4)     2 -4, 1, 3   

6 ADD(2)      2 -4, 1, 2, 3   

7 ADD(8)      2 -4, 1, 2, 3, 8   

8 ADD(-1000)  2 -1000, -4, 1, 2, 3, 8   

9 GET         3 -1000, -4, 1, 2, 3, 8                1 

10 GET        4 -1000, -4, 1, 2, 3, 8                2 

11 ADD(2)     4 -1000, -4, 1, 2, 2, 3, 8   

It is required to work out an efficient algorithm which treats a given sequence of transactions. The maximum number of ADD and GET transactions: 30000 of each type. 

Let us describe the sequence of transactions by two integer arrays: 

1. A(1), A(2), ..., A(M): a sequence of elements which are being included into Black Box. A values are integers not exceeding 2 000 000 000 by their absolute value, M <= 30000. For the Example we have A=(3, 1, -4, 2, 8, -1000, 2). 

2. u(1), u(2), ..., u(N): a sequence setting a number of elements which are being included into Black Box at the moment of first, second, ... and N-transaction GET. For the Example we have u=(1, 2, 6, 6). 

The Black Box algorithm supposes that natural number sequence u(1), u(2), ..., u(N) is sorted in non-descending order, N <= M and for each p (1 <= p <= N) an inequality p <= u(p) <= M is valid. It follows from the fact that for the p-element of our u sequence
we perform a GET transaction giving p-minimum number from our A(1), A(2), ..., A(u(p)) sequence. 

Input

Input contains (in given order): M, N, A(1), A(2), ..., A(M), u(1), u(2), ..., u(N). All numbers are divided by spaces and (or) carriage return characters.

Output

Write to the output Black Box answers sequence for a given sequence of transactions, one number each line.

Sample Input

7 4
3 1 -4 2 8 -1000 2
1 2 6 6

Sample Output

3
3
1
2
#include <stdio.h>
#include <string.h>
#include <queue>
#include <iostream>

using namespace std;

int main()
{
    int i, t, a[30010], n, m, x, c;
    while(~scanf("%d %d",&n, &m))
    {
        c = 0;
        priority_queue<int , vector<int>, greater<int> >q;
        priority_queue<int , vector<int>, less <int> >p;
        for(i = 0; i < n; i++)
            scanf("%d",&a[i]);
        for(i = 0; i < m; i++)
        {
            scanf("%d",&x);
            while(c < x)
                q.push(a[c++]);
            while(!p.empty() && p.top() > q.top())
            {
                t = p.top();
                p.pop();
                p.push(q.top());
                q.pop();
                q.push(t);
            }
            printf("%d\n",q.top());
            p.push(q.top());
            q.pop();
        }
    }
    return 0;
}


抱歉!评论已关闭.