现在的位置: 首页 > 综合 > 正文

HDU1297 Children’s Queue

2013年12月05日 ⁄ 综合 ⁄ 共 1401字 ⁄ 字号 评论关闭

                                                       Children’s Queue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8602    Accepted Submission(s): 2722

Problem Description
There are many students in PHT School. One day, the headmaster whose name is PigHeader wanted all students stand in a line. He prescribed that girl can not be in single. In other words, either no girl in the queue or more than one
girl stands side by side. The case n=4 (n is the number of children) is like
FFFF, FFFM, MFFF, FFMM, MFFM, MMFF, MMMM
Here F stands for a girl and M stands for a boy. The total number of queue satisfied the headmaster’s needs is 7. Can you make a program to find the total number of queue with n children?
 

Input
There are multiple cases in this problem and ended by the EOF. In each case, there is only one integer n means the number of children (1<=n<=1000)
 

Output
For each test case, there is only one integer means the number of queue satisfied the headmaster’s needs.
 

Sample Input
1 2 3
 

Sample Output
1 2 4
 

Author
SmallBeer (CML)
 

Source
 

Recommend
lcy

解题思路:因本题数据过大,用C不好处理,直接用了JAVA。递推公式:a[i] = a[i-1] +a[i-2] + a[i-4].

import java.util.*;
import java.math.BigInteger;;
public class Main {
    public static void main(String[] args) {
        Scanner as=new Scanner(System.in);
        int n;
        BigInteger[] a=new BigInteger[1001];
        a[0]=BigInteger.ONE;
        a[1]=BigInteger.ONE;
        a[2]=BigInteger.valueOf(2);
        a[3]=BigInteger.valueOf(4);
        for(int i=4;i<1001;i++)
            a[i]=a[i-1].add(a[i-2]).add(a[i-4]);
        while(as.hasNext())
        {
            n=as.nextInt();
            System.out.println(a[n]);
        }
    }
}

抱歉!评论已关闭.