现在的位置: 首页 > 综合 > 正文

1681 Painter’s Problem 开灯问题 枚举方法

2013年04月18日 ⁄ 综合 ⁄ 共 2329字 ⁄ 字号 评论关闭
Painter's Problem
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 2267   Accepted: 1119

Description

There is a square wall which is made of n*n small square bricks. Some bricks are white while some bricks are yellow. Bob is a painter and he wants to paint all the bricks yellow. But there is something wrong with Bob's brush. Once he uses this brush to paint brick (i, j), the bricks at (i, j), (i-1, j), (i+1, j), (i, j-1) and (i, j+1) all change their color. Your task is to find the minimum number of bricks Bob should paint in order to make all the bricks yellow.

Input

The first line contains a single integer t (1 <= t <= 20) that indicates the number of test cases. Then follow the t cases. Each test case begins with a line contains an integer n (1 <= n <= 15), representing the size of wall. The next n lines represent the original wall. Each line contains n characters. The j-th character of the i-th line figures out the color of brick at position (i, j). We use a 'w' to express a white brick while a 'y' to express a yellow brick.

Output

For each case, output a line contains the minimum number of bricks Bob should paint. If Bob can't paint all the bricks yellow, print 'inf'.

Sample Input

2
3
yyy
yyy
yyy
5
wwwww
wwwww
wwwww
wwwww
wwwww

Sample Output

0
15
#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
using namespace std;
const int inf=(1<<28);
int _min,n;
int map[20][20],res[20][20],g[20][20];
int direct[5][2] = {0, 0, -1, 0, 1, 0, 0, -1, 0, 1};
void press(int x, int y)
{
       int tx, ty;
       for (int i = 0; i < 5; i++)
       {
              tx = x + direct[i][0];
              ty = y + direct[i][1];
              if (tx >= 1 && ty >= 1 && tx <=n && ty <=n)
                     map[tx][ty] = !map[tx][ty];
       }
}
void sol()
{
    for(int cnt=0;cnt<=(1<<n);cnt++)//第一行有多少个1
    {
        memset(res,0,sizeof(res));
        memcpy(map,g,sizeof(g));
        int com[20]={0},t=cnt;
        for(int j=n;j>=1;j--) com[j]=t&1,t>>=1;
        int num=0;
        for(int j=1;j<=n;j++)  if(com[j]) press(1,j),res[1][j]=1,num++;//枚举
        for(int k=2;k<=n;k++)
        {
            for(int j=1;j<=n;j++)
            {
                if(map[k-1][j]) press(k,j),res[k][j]=1,num++;
            }
        }
        int flag=1;
        for(int j=1;j<=n;j++) if(map[n][j]){flag=0;break;}
        if(flag) _min=_min>num?num:_min;
    }
}
int main()
{
    int ci;scanf("%d",&ci);
    while(ci--)
    {
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        {
            string str;cin>>str;//黄0,白1
            for(int j=0;j<n;j++) g[i][j+1]=str[j]=='w';
        }
        _min=inf;
        sol();
        if(_min==inf) printf("inf/n");
        else printf("%d/n",_min);
    }
    return 0;
}

抱歉!评论已关闭.