现在的位置: 首页 > 综合 > 正文

HDU 1686 Oulipo

2013年02月10日 ⁄ 综合 ⁄ 共 2384字 ⁄ 字号 评论关闭
Problem Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination,
l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that
counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All
the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input
3 BAPC BAPC AZA AZAZAZA VERDI AVERDXIVYERDIAN

Sample Output
1 3 0
题目大意,看样例都懂...
就是匹配串,顺着主串滑动,求匹配次数...
#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;
char a[1000010];
char b[10010];
int next[10010];
int alen;
int blen;
void get_next()
{
    int i=1;
    int j=0;
    next[1]=0;
    while(i<=blen)           //这个i==len  注意。。。
    {
        /*如果i<len (AZA)   
                    (AZA)Z(AZA) 匹配数为2
          而i<=len  (AZA)
                    (AZ(A)Z(A)ZA) 匹配数为3 
                    仔细看看。。。 
        */
        if(j==0||b[i]==b[j])
        {
            ++ i;
            ++ j;
            next[i]=j;  
        }
        else
            j=next[j];
    }
}
void KMP()
{
    int count=0;
    int i=1;
    int j=1;
    while(i<=alen&&j<=blen)
    {
        if(j==0||a[i]==b[j])
        {
            ++ i;
            ++ j;
        }
        else
        j=next[j];
        if(j>blen)
        {
             count++;
             j=next[j];     //匹配成功后,挪到next[j]位置
        }
    }
    printf("%d\n",count);
}
int main()
{
    int n;
    scanf("%d",&n);
    while(n--)
    {
        scanf("%s%s",b+1,a+1);
        alen=strlen(a+1);
        blen=strlen(b+1);
        get_next();
        KMP();
    }
    return 0;
}

抱歉!评论已关闭.