现在的位置: 首页 > 综合 > 正文

poj 2253 Frogger-Flody(关于坐标距离的处理)

2014年02月15日 ⁄ 综合 ⁄ 共 2634字 ⁄ 字号 评论关闭

Frogger
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 19357   Accepted: 6301

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her
by jumping. 
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's
stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line
after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

代码:

#include<cstdio>
#include<cstdlib>
#include<iostream>
#include<algorithm>
#include<string>
#include<cstring> 
#include<cmath>
#include<queue>
using namespace std;
#define sf scanf
#define pf printf
#define INF 1<<29
#define eps 1e-6
const double PI=acos(-1.0);
#define lint __int64
#define LL long long 
#define ULLint unsigned long long //2^64-1>1.8*10^19
#define clr(x) memset(x,0,sizeof(x))
#define Clr(x) memset(x,-1,sizeof(x))
double Imax(double a,double b){
	if(a>b) return a;
	else return b;
}
double len(double x1,double y1,double x2,double y2){
	return sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
}
const int Max=205;
double dis[Max][Max];
double cord[Max][2];
int n;
void floyd(){
	int i,j,k;
	for(k=1;k<=n;k++)
		for(i=1;i<=n;i++)
			for(j=i;j<=n;j++){
				if(Imax(dis[i][k],dis[k][j])<dis[i][j])
					dis[i][j]=dis[j][i]=Imax(dis[i][k],dis[k][j]);
			}
}
int main(){
	int cas=1;
	int i,j;
	while(cin>>n&&n){
		for(i=1;i<=n;i++)
			cin>>cord[i][0]>>cord[i][1];
		for(i=1;i<=n;i++)
			for(j=1;j<=n;j++)
				dis[i][j]=dis[j][i]=len(cord[i][0],cord[i][1],cord[j][0],cord[j][1]);
		floyd();
		cout<<"Scenario #"<<cas++<<endl;
		cout<<"Frog Distance = ";
		printf("%.3f",dis[1][2]);
		cout<<endl<<endl;
	}
	return 0;
}

抱歉!评论已关闭.