现在的位置: 首页 > 综合 > 正文

BNU16495:Light Bulbs

2013年01月17日 ⁄ 综合 ⁄ 共 2658字 ⁄ 字号 评论关闭

Wildleopard had fallen in love with his girlfriend for 20 years. He wanted to end the long match for their love and get married this year. He bought a new house for his family and hired a company to decorate his house. Wildleopard and his fiancee were very
satisfied with the postmodern design, except the light bulbs. Varieties of light bulbs were used so that the light in the house differed a lot in different places. Now he asks you, one of his best friends, to help him find out the point of maximum illumination.

To simplify the problem, we can assume each bulb is a point light source and we only need to consider the grid points of the flat floor of the house. A grid point is a point whose coordinates are both integers. The length and the width of house can be considered
infinite. Illumination means the amount of light that go through in one unit area. The illumination of a point can be calculated by simply adding the illumination from each source. The illumination from a source can be calculated by the following equation:

, where E is the illumination of the point, I is the luminous intensity of the source,
R is the distance between the source and the point and i is the angle between the normal of the plane and the light to the point.

Given the position and the luminous intensity of the light bulbs, you are asked to find the maximum illumination on the floor at the grid points.

Input

Standard input will contain multiple test cases. The first line of the input is a single integer
T (1 <= T <= 20) which is the number of test cases. And it will be followed by
T consecutive test cases.

The first line of each test case contains one integer n(1 <= n <= 100), indicating the number of bulbs of the lamps in the house. The next
n lines will contain 4 integers each, Xi, Yi,
Zi, Ii, separated by one space, indicating the coordinates and the luminous intensity of the
i-th bulb of the lamp. The absolute values of the coordinates do not exceed 100 and
Zi is always positive. Ii is a positive integer less than 32768.

Output

Results should be directed to standard output. The output of each test case should be a real number rounded to 0.01, which is the maximum illumination on the floor at the grid points.

Sample Input

3
1
0 0 1 100
4
1 0 1 100
0 1 1 100
-1 0 1 100
0 -1 1 100
4
1 0 100 10000
0 1 100 10000
-1 0 100 10000
0 -1 100 10000

Sample Output

100.00
147.43
4.00
 
题意:一开始还以为是什么高深的数学题,毕竟看到几何图了- -,然后题意又坑了半天,一直纠结z是啥,后来才发现灯泡原来是三维坐标,汗~然后看清楚题意了其实很简单,就是套用公式求出房间最亮的那个点的亮度
 
思路:由于房间水平坐标的x,y绝对值在100以内,所以直接枚举套用公式即可
 
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <math.h>
using namespace std;

struct node
{
    double x,y,z,l;
}a[105];

int n;

double solve(double x,double y)
{
    double r,bi;
    double ans = 0;
    int i;
    for(i = 0;i<n;i++)
    {
        r = sqrt(a[i].z*a[i].z+(a[i].x-x)*(a[i].x-x)+(a[i].y-y)*(a[i].y-y));//半径
        bi = a[i].z/r;//cos的值
        ans+=a[i].l*bi/r/r;//公式
    }
    return ans;
}

int main()
{
    int t,i,j;
    double maxn,k;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        maxn = 0;
        for(i = 0;i<n;i++)
        scanf("%lf%lf%lf%lf",&a[i].x,&a[i].y,&a[i].z,&a[i].l);
        for(i = -100;i<=100;i++)
        {
            for(j = -100;j<=100;j++)//枚举
            {
                k = solve(i,j);
                maxn = max(maxn,k);
            }
        }
        printf("%.2f\n",maxn);
    }

    return 0;
}

抱歉!评论已关闭.