现在的位置: 首页 > 综合 > 正文

HDU1009

2014年06月12日 ⁄ 综合 ⁄ 共 1693字 ⁄ 字号 评论关闭

                          

FatMouse' Trade

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 37520    Accepted Submission(s): 12395

Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of
cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case
is followed by two -1's. All integers are not greater than 1000.
 

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 

Sample Input
5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1
 

Sample Output
13.333 31.500
 

Author
CHEN, Yue

 

这是一道关于贪心的问题。这道题的大意是就是给定猫食的总量然后去和猫换JAVABEAN,每个房间都有JAVABEAN当然每个房间需要的猫食不同。你要求的是利用有限的猫食换取最多的JAVABEAN。

 

 

#include<stdio.h>
int main()
{
    int temp1,k,s,i,food,home;
    while(scanf("%d%d",&food,&home)!=EOF&&(food!=-1&&home!=-1))
    {
        double a[1001];
    int f[1001];
    int j[1001];
    double sum=0;
    double temp;

        for(i=0;i<home;i++)
        {
            scanf("%d%d",&j[i],&f[i]);
            a[i]=j[i]*1.0/f[i]*1.0;
        }
        for(k=0;k<home;k++)

            for(s=0;s<home-1;s++)
            {


             if(a[s]<a[s+1])
                {
                    temp=a[s];
                    a[s]=a[s+1];
                    a[s+1]=temp;
                    temp1=f[s];
                    f[s]=f[s+1];
                    f[s+1]=temp1;
                    temp1=j[s];
                    j[s]=j[s+1];
                    j[s+1]=temp1;

                }

            }

        for(i=0;i<home;i++)
    {
        if(food>=f[i])
        {
             sum=sum+j[i];
          food=food-f[i];

        }
        else
       {

           sum=sum+food*a[i];
            break ;
               }
    }

    printf("%.3f\n",sum);

    }

    return 0;
}

 

 

 

 

抱歉!评论已关闭.