现在的位置: 首页 > 综合 > 正文

HDU2602 Bone Collector

2014年06月12日 ⁄ 综合 ⁄ 共 1518字 ⁄ 字号 评论关闭

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 24147    Accepted Submission(s): 9798

Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the
maximum of the total value the bone collector can get ?

 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third
line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 231).
 

Sample Input
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
14
 

Author

Teddy

 

做的第一个背包题,个人感觉理解背包类问题解题方法(动态规划)是解题正确的关键

感觉此类问题与递推有较大的联系。一点拙见,不对之处请各位多多指教。代码如下:

 

 

#include<stdio.h>
#include<string.h>
int bone[1001];
struct sa
{
    int W,V;
}data[1001];
int max(int a,int b)
{
    return a>b?a:b;
}
int main()
{
    int t,i,j;
    while(scanf("%d",&t)!=EOF)
    {
    while(t--)
    {
        memset(bone,0,sizeof(bone));
        int n,v;
        scanf("%d%d",&n,&v);
        for(i=1;i<=n;i++)
        scanf("%d",&data[i].W);
        for(j=1;j<=n;j++)
        scanf("%d",&data[j].V);
        for(i=1;i<=n;i++)
        for(j=v;j>=data[i].V;j--)
        {
            bone[j]=max(bone[j],bone[j-data[i].V]+data[i].W);
        }
        printf("%d\n",bone[v]);
    }
    }
    return 0;
}

 

【上篇】
【下篇】

抱歉!评论已关闭.