现在的位置: 首页 > 综合 > 正文

poj 3009 Curling 2.0 DFS

2014年09月05日 ⁄ 综合 ⁄ 共 4045字 ⁄ 字号 评论关闭
Curling 2.0
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 9485   Accepted: 4003

Description

On Planet MM-21, after their Olympic games this year, curling is getting popular. But the rules are somewhat different from ours. The game is played on an ice game board on which a square mesh is marked. They use only a single stone. The purpose of the game
is to lead the stone from the start to the goal with the minimum number of moves.

Fig. 1 shows an example of a game board. Some squares may be occupied with blocks. There are two special squares namely the start and the goal, which are not occupied with blocks. (These two squares are distinct.) Once the stone begins to move, it will proceed
until it hits a block. In order to bring the stone to the goal, you may have to stop the stone by hitting it against a block, and throw again.


Fig. 1: Example of board (S: start, G: goal)

The movement of the stone obeys the following rules:

  • At the beginning, the stone stands still at the start square.
  • The movements of the stone are restricted to x and y directions. Diagonal moves are prohibited.
  • When the stone stands still, you can make it moving by throwing it. You may throw it to any direction unless it is blocked immediately(Fig. 2(a)).
  • Once thrown, the stone keeps moving to the same direction until one of the following occurs:
    • The stone hits a block (Fig. 2(b), (c)).

      • The stone stops at the square next to the block it hit.
      • The block disappears.
    • The stone gets out of the board.
      • The game ends in failure.
    • The stone reaches the goal square.
      • The stone stops there and the game ends in success.
  • You cannot throw the stone more than 10 times in a game. If the stone does not reach the goal in 10 moves, the game ends in failure.


Fig. 2: Stone movements

Under the rules, we would like to know whether the stone at the start can reach the goal and, if yes, the minimum number of moves required.

With the initial configuration shown in Fig. 1, 4 moves are required to bring the stone from the start to the goal. The route is shown in Fig. 3(a). Notice when the stone reaches the goal, the board configuration has changed as in Fig. 3(b).


Fig. 3: The solution for Fig. D-1 and the final board configuration

Input

The input is a sequence of datasets. The end of the input is indicated by a line containing two zeros separated by a space. The number of datasets never exceeds 100.

Each dataset is formatted as follows.

the width(=w) and the height(=h) of the board 
First row of the board
 
... 
h-th row of the board

The width and the height of the board satisfy: 2 <= w <= 20, 1 <= h <= 20.

Each line consists of w decimal numbers delimited by a space. The number describes the status of the corresponding square.

0 vacant square
1 block
2 start position
3 goal position

The dataset for Fig. D-1 is as follows:

6 6 
1 0 0 2 1 0 
1 1 0 0 0 0 
0 0 0 0 0 3 
0 0 0 0 0 0 
1 0 0 0 0 1 
0 1 1 1 1 1

Output

For each dataset, print a line having a decimal integer indicating the minimum number of moves along a route from the start to the goal. If there are no such routes, print -1 instead. Each line should not have any character other than this number.

Sample Input

2 1
3 2
6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1
6 1
1 1 2 1 1 3
6 1
1 0 2 1 1 3
12 1
2 0 1 1 1 1 1 1 1 1 1 3
13 1
2 0 1 1 1 1 1 1 1 1 1 1 3
0 0

Sample Output

1
4
-1
4
10
-1

Source Code

Problem: 3009		
Memory: 176K		Time: 110MS
Language: C++		Result: Accepted
Source Code
#include <cstdio>

const int MAX = 21;
int W, H;
int board[MAX][MAX];

int min(int a, int b)
{
	return a>b? b:a;
}

int DFS(int x,int y, int step)
{

	if(step > 10)
	{
		return -1;
	}

	int tmp_res = 100;
	
	// 飘到左边 
	if(board[x][y-1]!=1)
	{
		for(int a=y-1; a >= 0; a--)
		{	
			if(board[x][a]==3)	return step;
			if(board[x][a]==1)
			{
				board[x][a] = 0;
				int temp = DFS(x, a+1, step+1);
				tmp_res = temp == -1? tmp_res :min(temp, tmp_res);
				board[x][a] = 1;
				break;
			}
		}
	}
	// 飘到右边 
	if(board[x][y+1]!=1)
	{
		for(int b=y+1; b < W; b++)
		{
			if(board[x][b]==3)	return step;
			if(board[x][b]==1)
			{
				board[x][b]=0;
				int temp  = DFS(x, b-1, step+1);
				tmp_res = temp == -1? tmp_res :min(temp, tmp_res);
				board[x][b]=1;
				break;
			}
		}
	}
	// 飘到上边
	if(board[x-1][y]!=1)
	{
		for(int up=x-1; up>=0; up--)
		{
			if(board[up][y]==3)	return step;
			if(board[up][y]==1)
			{
				board[up][y] = 0;
				int temp = DFS(up+1, y, step+1);
				tmp_res = temp == -1? tmp_res :min(temp, tmp_res);
				board[up][y] = 1;
				break;
			}
		} 
	}
	// 飘到下边
	if(board[x+1][y]!=1)
	{
		for(int down=x+1; down < H; down++)
		{
			if(board[down][y]==3)	return step;
			if(board[down][y]==1)
			{
				board[down][y] = 0;
				int temp = DFS(down-1, y, step+1);
				tmp_res = temp == -1? tmp_res :min(temp, tmp_res);
				board[down][y] = 1;
				break;
			}
		} 
	}
	if(tmp_res==100)
		return -1;
	return tmp_res;
}

int main()
{
//	freopen("in.txt","r",stdin);
	int startx, starty;
	while(scanf("%d %d", &W, &H) && W !=0 && H!= 0)
	{
		for(int i=0; i < H; i++)
			for(int j=0; j < W; j++)
			{
				scanf("%d", &board[i][j]);
		
				if(board[i][j]==2){
					startx = i;
					starty = j;
				}
			}
			
		printf("%d\n",DFS(startx, starty, 1));		
	}
	return 0;
}

抱歉!评论已关闭.