现在的位置: 首页 > 综合 > 正文

ZOJ3329-One Person Game(概率DP求数学期望)

2014年11月13日 ⁄ 综合 ⁄ 共 2079字 ⁄ 字号 评论关闭

One Person Game


Time Limit: 1 Second     
Memory Limit:
32768 KB      Special Judge


There is a very simple and interesting one-person game. You have 3 dice, namelyDie1,
Die2 and Die3. Die1 hasK1 faces.
Die2 has K2 faces.Die3 has
K3
faces. All the dice are fair dice, so the probability of rolling each value, 1 toK1,
K2, K3 is exactly 1 /K1, 1 /
K2 and 1 / K3. You have a counter, and the game is played as follow:

  1. Set the counter to 0 at first.
  2. Roll the 3 dice simultaneously. If the up-facing number of Die1 isa, the up-facing number of
    Die2 is b and the up-facing number ofDie3 is
    c, set the counter to 0. Otherwise, add the counter by the total value of the 3 up-facing numbers.
  3. If the counter's number is still not greater than n, go to step 2. Otherwise the game is ended.

Calculate the expectation of the number of times that you cast dice before the end of the game.

Input

There are multiple test cases. The first line of input is an integer T (0 <T <= 300) indicating the number of test cases. Then
T test cases follow. Each test case is a line contains 7 non-negative integersn,
K1, K2, K3,a,
b, c (0 <= n <= 500, 1 < K1,K2,
K3 <= 6, 1 <= a <= K1, 1 <=b <=
K2, 1 <= c <= K3).

Output

For each test case, output the answer in a single line. A relative error of 1e-8 will be accepted.

Sample Input

2
0 2 2 2 1 1 1
0 6 6 6 1 1 1

Sample Output

1.142857142857143
1.004651162790698


题意:3个骰子,分别为k1,k2,k3面,每次三个骰子掷到a,b,c时,分数置为0,否则将分数加到计数器上,当计数器的分数大于n时,游戏结束,问游戏 结束的步数的数学期望

DP[i] = SUM(DP[i+k]*Pk)+DP[0]*p0+1
因为要求的是DP[0] 因此可以看成 一个常数
DP[i] = A[i]*DP[0] + B[i]
将DP[i+k]带入式子1,化简得
DP[i] = DP[0]*(sum(A[i+k])*Pk+p0)+sum(B[i+k]*Pk)+1
得出
A[i] = sum(A[i+k])*Pk+p0
B[i] = sum(B[i+k])*Pk+1
DP[0] = B[0]/(1-A[0])
算概率的时候要注意a,b,c的情况不能算入P(a+b+c)中

#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <string>
#include <algorithm>
#include <queue>
using namespace std;
const int maxn = 500+10;
int n,k1,k2,k3,a,b,c;
double A[maxn],B[maxn];
double P[20];
int main(){

    int ncase;
    cin >> ncase;
    while(ncase--){
        scanf("%d%d%d%d%d%d%d",&n,&k1,&k2,&k3,&a,&b,&c);
        double p0 = 1.0/(k1*k2*k3);
        for(int i = 3; i <= k1+k2+k3; i++)
            P[i] = 0.0;
        for(int i = 1; i <= k1; i++)
            for(int j = 1; j <= k2; j++)
                for(int k = 1; k <= k3; k++)
                    if(!(i==a&&j==b&&k==c))
                        P[i+j+k] += p0;

        memset(A,0,sizeof  A);
        memset(B,0,sizeof B);
        for(int i = n; i >= 0; i--){
            A[i] = p0;
            B[i] =  1;
            for(int k = 3; k <= k1+k2+k3; k++){
                if(i+k<=n){
                    A[i] += A[i+k]*P[k];
                    B[i] += B[i+k]*P[k];
                }
            }
        }
        printf("%.8lf\n",B[0]/(1-A[0]));
    }
    return 0;
}




抱歉!评论已关闭.