现在的位置: 首页 > 综合 > 正文

POJ 1651-Multiplication Puzzle

2014年11月13日 ⁄ 综合 ⁄ 共 1589字 ⁄ 字号 评论关闭

Multiplication Puzzle
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5792 Accepted: 3506
Description

The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on
the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row.

The goal is to take cards in such order as to minimize the total number of scored points.

For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring

10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000

If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be

1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.
Input

The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.
Output

Output must contain a single integer - the minimal score.
Sample Input

6
10 1 50 50 20 5
Sample Output

3650
Source

Northeastern Europe 2001, Far-Eastern Subregion

区间DP
DP[sta][ed] = min(DP[sta][i]+D[i][ed]+num[i]*num[sta][ed]) sta < i < ed
取的那个数可以理解成两个划分区间后最后剩下的数(与sta,ed相邻)
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int maxn = 100+10;
const int INF = 1e9;
int n;
int num[maxn];
int dp[maxn][maxn];
int dfs(int sta,int ed){
    if(ed-sta<2) return 0;
    if(dp[sta][ed] != -1) return dp[sta][ed];
    int ans = INF;
    for(int i = sta+1; i < ed; i++){
        ans = min(ans,dfs(sta,i)+dfs(i,ed)+num[sta]*num[i]*num[ed]);
    }
    return dp[sta][ed] = ans;
}

int main(){

    while(cin >> n){
        for(int i = 0; i < n; i++) cin >> num[i];
        memset(dp,-1,sizeof dp);
        cout<<dfs(0,n-1)<<endl;
    }

    return 0;
}

抱歉!评论已关闭.