现在的位置: 首页 > 综合 > 正文

【ACM Steps】Wolf and Rabbit

2015年02月12日 ⁄ 综合 ⁄ 共 1043字 ⁄ 字号 评论关闭

Wolf and Rabbit

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1252 Accepted Submission(s): 726
 
Problem Description
There is a hill with n holes around. The holes are signed from 0 to n-1.

A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are
signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes.

 
Input
The input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648).
 
Output

            For each input m n, if safe holes exist, you should output "YES", else output "NO" in a single line.
 
Sample Input
2
1 2
2 2
 
Sample Output
NO
YES
 
 
#include <iostream>

using namespace std;

int gcd(int x,int y)
{
	int c;
	if(x<c)
	{
		c=x;
		x=y;
		y=c;
	}
	if(y==0)
	return x;
	else return gcd(y,x%y);	 
}

int main()
{
	int n;
	cin>>n;
	while(n--)
	{
		int a,b;
		cin>>a>>b;
		if(gcd(a,b)==1) cout<<"NO"<<endl;
		else cout<<"YES"<<endl;
	}
	return 0;
} 

抱歉!评论已关闭.