现在的位置: 首页 > 综合 > 正文

POJ1789 Truck History【Prim】

2015年06月17日 ⁄ 综合 ⁄ 共 2857字 ⁄ 字号 评论关闭
Truck History

Time Limit: 2000MS
Memory Limit: 65536K
Total Submissions: 19456
Accepted: 7498

Description

Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase
letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from the new types another types
were derived, and so on. 

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different
letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as 
1/Σ(to,td)d(to,td)

where the sum goes over all pairs of types in the derivation plan such that to is the original type and td the type derived from it and d(to,td) is the distance of the types. 
Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan. 


Input


The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that
the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.


Output


For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.


Sample Input

4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0


Sample Output

The highest possible quality is 1/3.


Source

CTU Open 2003


题目大意:给你N个字符串,每个字符串代表一个结点,每个结点之间的距离为字符串中

不同字符的个数。比如:"abaaaaa"和"aabaaaa",第二个和第三个字符不同,两个结点

之间的距离就是2。以此类推,得到所有的结点。求所有结点构成图的最小生成树。

思路:按题意算出各结点之间的距离,存入图中,用Prim算法求解,注意输出格式。


#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;

int Map[2010][2010];
char MAP[2010][8];
int low[2010],vis[2010];

int Prim(int N)
{
    memset(vis,0,sizeof(vis));
    int ans = 0;
    vis[1] = 1;
    int pos = 1;
    for(int i = 1; i <= N; ++i)
        if(i != pos)
            low[i] = Map[pos][i];

    for(int i = 1; i < N; ++i)
    {
        int Min = 0xffffff0;
        for(int j = 1; j <= N; ++j)
        {
            if(Min > low[j] && !vis[j])
            {
                 Min = low[j];
                 pos = j;
            }   
        }
        ans += Min;
        vis[pos] = 1;
        for(int j = 1; j <= N; ++j)
        {
            if(!vis[j] && Map[pos][j] < low[j])
            {
                low[j] = Map[pos][j];
            }
        }
    }
    return ans;
}

void GetMap(int N)
{
    memset(Map,0xffffff0,sizeof(Map));
    for(int i = 1; i <= N; ++i)
    {
        for(int j = i; j <= N; ++j)
        {
            int sum = 0;
            for(int k = 0; k < 7; ++k)
            {
                if(MAP[i][k] != MAP[j][k])
                    sum++;
            }
            Map[i][j] = Map[j][i] = sum;
            if(i == j)
                Map[i][j] = 0;
        }
    }
}
int main()
{
    int N;
    while(~scanf("%d",&N) && N)
    {
        memset(MAP,0,sizeof(MAP));
        for(int i = 1; i <= N; ++i)
            scanf("%s",MAP[i]);
        GetMap(N);
        int ans = Prim(N);
        printf("The highest possible quality is 1/%d.\n",ans);
    }
    return 0;
}

抱歉!评论已关闭.