现在的位置: 首页 > 综合 > 正文

POJ2063 Investment 【完全背包】

2015年12月01日 ⁄ 综合 ⁄ 共 3077字 ⁄ 字号 评论关闭
Investment
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 8019   Accepted: 2747

Description

John never knew he had a grand-uncle, until he received the notary's letter. He learned that his late grand-uncle had gathered a lot of money, somewhere in South-America, and that John was the only inheritor. 
John did not need that much money for the moment. But he realized that it would be a good idea to store this capital in a safe place, and have it grow until he decided to retire. The bank convinced him that a certain kind of bond was interesting for him. 
This kind of bond has a fixed value, and gives a fixed amount of yearly interest, payed to the owner at the end of each year. The bond has no fixed term. Bonds are available in different sizes. The larger ones usually give a better interest. Soon John realized
that the optimal set of bonds to buy was not trivial to figure out. Moreover, after a few years his capital would have grown, and the schedule had to be re-evaluated. 
Assume the following bonds are available: 

Value Annual
interest
4000
3000
400
250



With a capital of e10 000 one could buy two bonds of $4 000, giving a yearly interest of $800. Buying two bonds of $3 000, and one of $4 000 is a better idea, as it gives a yearly interest of $900. After two years the capital has grown to $11 800, and it makes
sense to sell a $3 000 one and buy a $4 000 one, so the annual interest grows to $1 050. This is where this story grows unlikely: the bank does not charge for buying and selling bonds. Next year the total sum is $12 850, which allows for three times $4 000,
giving a yearly interest of $1 200. 
Here is your problem: given an amount to begin with, a number of years, and a set of bonds with their values and interests, find out how big the amount may grow in the given period, using the best schedule for buying and selling bonds.

Input

The first line contains a single positive integer N which is the number of test cases. The test cases follow. 
The first line of a test case contains two positive integers: the amount to start with (at most $1 000 000), and the number of years the capital may grow (at most 40). 
The following line contains a single number: the number d (1 <= d <= 10) of available bonds. 
The next d lines each contain the description of a bond. The description of a bond consists of two positive integers: the value of the bond, and the yearly interest for that bond. The value of a bond is always a multiple of $1 000. The interest of a bond is
never more than 10% of its value.

Output

For each test case, output – on a separate line – the capital at the end of the period, after an optimal schedule of buying and selling.

Sample Input

1
10000 4
2
4000 400
3000 250

Sample Output

14050

题意:给定一个容量为weight的背包而且一开始本金为weight,再给定n个物品,每种物品的重量是w[i],价值是v[i],数量无限。将这n种物品有选择的装入背包中,使背包价值最大,一年后本金会加上背包中的价值,然后重新分配背包物品,给定年份m,求m年后本金是多少。

题解:由于每种物品的重量都是1000的倍数,所以可以将每种物品和背包容量/=1000以减少内存消耗,由于1000000*1.1^40 / 1000 = 45000多,所以dp数组开到5万就足够了,剩下的就是完全背包问题了,将每年获得的最大价值加入本金中,最后再输出本金即可。状态转移方程:dp[i][j] = max(dp[i-1][j-k*w[i] + k*v[i]),0<=k<=totalWeight/v[i];压缩成一维数组后内层循环顺序

#include <stdio.h>
#include <string.h>
#define maxn 50000

int dp[maxn], w[42], v[42];

int main()
{
    int t, totalWeight, years, i, j, capital, n;
    scanf("%d", &t);
    while(t--){
        scanf("%d%d", &totalWeight, &years);
        capital = totalWeight;
        scanf("%d", &n);
        for(i = 1; i <= n; ++i){
            scanf("%d%d", &w[i], &v[i]);
            w[i] /= 1000;
        }
        while(years--){
            totalWeight = capital / 1000;
            memset(dp, 0, sizeof(dp));
            for(i = 1; i <= n; ++i){
                for(j = w[i]; j <= totalWeight; ++j){
                    if(dp[j] < dp[j - w[i]] + v[i]) 
                        dp[j] = dp[j - w[i]] + v[i];
                }
            }
            capital += dp[totalWeight];
        }
        printf("%d\n", capital);
    }
    return 0;
}

抱歉!评论已关闭.