现在的位置: 首页 > 综合 > 正文

HDU1114 Piggy-Bank 【完全背包】

2015年12月01日 ⁄ 综合 ⁄ 共 3041字 ⁄ 字号 评论关闭

Piggy-Bank

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 11149    Accepted Submission(s): 5632
Problem Description
Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has
any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay
everything that needs to be paid.

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility
is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank
that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!

 

Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled
with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency.
Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams.
 

Output
Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total
weight. If the weight cannot be reached exactly, print a line "This is impossible.".
 

Sample Input
3 10 110 2 1 1 30 50 10 110 2 1 1 50 30 1 6 2 10 3 20 4
 

Sample Output
The minimum amount of money in the piggy-bank is 60. The minimum amount of money in the piggy-bank is 100. This is impossible.

题意:给定一个空储钱罐的重量和满储钱罐的重量。再给定一些硬币种类的价值和重量,每一种硬币都有无数个。问:在储钱罐里怎样放硬币能使得总价值最小且总重量正好和满储钱罐重量相等。

题解:完全背包入门题。状态转移方程为dp[i][j] = min(dp[i-1][j-k*w[i]] + k*v[i]) 0<=k<=totalWeight/w[i],跟01背包一样,完全背包dp数组也可以压缩成一维数组。只不过内层循环要顺序,而01背包是逆序

另外这题在初始化dp数组时有个陷阱:对于在函数外定义的数组,若对它使用memset(dp + 1, -1, sizeof(dp + 1));那么将只有一个元素被初始化为-1,其余的全为0.但是若是memset(dp, -1, sizeof(dp));数组就可以全部初始化为-1。

#include <stdio.h>
#include <string.h>

int dp[10002];

int main()
{
    int totalWeight, weight, val, n, t, i, j;
    scanf("%d", &t);
    while(t--){
        scanf("%d%d", &weight, &totalWeight);
        totalWeight -= weight;
        scanf("%d", &n);
        memset(dp + 1, -1, sizeof(int) * 10001); 
        for(i = 1; i <= n; ++i){
            scanf("%d%d", &val, &weight);
            for(j = weight; j <= totalWeight; ++j){
                if(dp[j - weight] != -1){
                    if(dp[j] == -1 || dp[j] > dp[j - weight] + val)
                        dp[j] = dp[j - weight] + val;
                }
            }
        }
        if(dp[totalWeight] == -1) printf("This is impossible.\n");
        else printf("The minimum amount of money in thepiggy-bank is %d.\n",
			 dp[totalWeight]);
    }
    return 0;
}

抱歉!评论已关闭.