现在的位置: 首页 > 综合 > 正文

POJ 题目1740 A New Stone Game(博弈)

2015年12月11日 ⁄ 综合 ⁄ 共 1693字 ⁄ 字号 评论关闭
A New Stone Game
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 4983   Accepted: 2726

Description

Alice and Bob decide to play a new stone game.At the beginning of the game they pick n(1<=n<=10) piles of stones in a line. Alice and Bob move the stones in turn. 
At each step of the game,the player choose a pile,remove at least one stones,then freely move stones from this pile to any other pile that still has stones. 
For example:n=4 and the piles have (3,1,4,2) stones.If the player chose the first pile and remove one.Then it can reach the follow states. 
2 1 4 2 
1 2 4 2(move one stone to Pile 2) 
1 1 5 2(move one stone to Pile 3) 
1 1 4 3(move one stone to Pile 4) 
0 2 5 2(move one stone to Pile 2 and another one to Pile 3) 
0 2 4 3(move one stone to Pile 2 and another one to Pile 4) 
0 1 5 3(move one stone to Pile 3 and another one to Pile 4) 
0 3 4 2(move two stones to Pile 2) 
0 1 6 2(move two stones to Pile 3) 
0 1 4 4(move two stones to Pile 4) 
Alice always moves first. Suppose that both Alice and Bob do their best in the game. 
You are to write a program to determine who will finally win the game. 

Input

The input contains several test cases. The first line of each test case contains an integer number n, denoting the number of piles. The following n integers describe the number of stones in each pile at the beginning of the game, you may assume the number of
stones in each pile will not exceed 100. 
The last test case is followed by one zero. 

Output

For each test case, if Alice win the game,output 1,otherwise output 0. 

Sample Input

3
2 1 3
2
1 1
0

Sample Output

1
0

Source

题目意思:有n堆石子,每一次取石子可以分两步,第一步从某一堆取1个,第二步可以从这一堆中取任意个给其他堆
思路:当有n堆是先手各种赢,当为偶数堆时,每一堆个数是对称的时先手输,否则都是先手赢
ac代码
#include<stdio.h>
#include<string.h>
int a[1110];
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF,n)
	{
		int i,j,s=0;
		memset(a,0,sizeof(a));
		for(i=0;i<n;i++)
		{
			int num;
			scanf("%d",&num);
			a[num]++;
		}
		if(n&1)
		{
			printf("1\n");
			continue;
		}
		for(i=0;i<=100;i++)
			if(a[i]%2==1)
				s++;
		if(s)
			printf("1\n");
		else
			printf("0\n");
	}
}

抱歉!评论已关闭.