现在的位置: 首页 > 综合 > 正文

HDOJ Bone Collector (0/1背包)

2017年10月18日 ⁄ 综合 ⁄ 共 2237字 ⁄ 字号 评论关闭

     

Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the
maximum of the total value the bone collector can get ?

 


Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third
line contain N integers representing the volume of each bone.
 


Output
One integer per line representing the maximum of the total value (this number will be less than 231).
 


Sample Input
1 5 10 1 2 3 4 5 5 4 3 2 1
 


Sample Output
14
 


Author
Teddy

 

          0/1 背包的典型应用,不过对于数据还是要注意点,因为骨头的体积可以是零。

           具体的状态转移方程:

                            f [ i ][ v ] = max ( f[ i - 1] [ v - v[ i ] ] + w[ i ], f[ i - 1] [ v ])

           也可以用一维数组

                           f[ v ] = max( f[ v ], f[v - v[ i ]] + w[ i ])

           一维的要从v -> 0 循环,二维的就是 0 -> v循环

         然后注意下menset  就差不多了。  

           最近开始狠抓 dp  所以 一步一步的努力学好,一点一点积累 加油!

   贴个二维代码  :

#include <stdio.h>
#include <string.h>
#define N 1010

int dp[N][N];
int value[N];
int V[N];

int max(int a,int b){
    return a > b ? a : b;
}

int main()
{
    int i,n,v,t,j;
    scanf("%d",&t);
    while(t--){
        scanf("%d%d",&n,&v);

        for(i = 1; i <= n; i++){
            scanf("%d",&value[i]);
        }
        for(i = 1; i <= n; i++){
            scanf("%d",&V[i]);
        }
        memset(dp,0,sizeof(dp));

        for(i = 1; i <= n; i++){
            for(j = 0; j <= v ; j++){
                if(j >= V[i])
                dp[i][j] = max(dp[i - 1][ j - V[i]] + value[i],dp[i-1][j]);
                else
                dp[i][j] = dp[i - 1][j];
            }
        }


        printf("%d\n",dp[n][v]);
    }
    return 0;
}

一维代码:

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <stdlib.h>
#include <map>
#include <set>
#include <vector>
#include <stack>
#include <queue>
#include <algorithm>

using namespace std;

#define mst(a,b) memset(a,b,sizeof(a))
#define eps 10e-8

const int MAX_ = 1010;
const int N = 100010;
const int INF = 0x7fffffff;

struct node{
    int value, v;
}a[MAX_];

int dp[MAX_];
int n, m;

int main(){
    int s, t, v, T;
    scanf("%d",&T);
	while(T--){
	    scanf("%d%d",&n,&m);
	    mst(dp,0);
	    for(int i = 1; i <= n; ++i){
            scanf("%d",&a[i].value);
	    }

        for(int i = 1; i <= n; ++i){
            scanf("%d",&a[i].v);
	    }

	    for(int i = 1; i <= n; ++i){
            for(int j = m; j >= a[i].v; --j){
                dp[j] = max(dp[j], dp[j - a[i].v] + a[i].value);
            }
	    }

        printf("%d\n",dp[m]);
	}
	return 0;
}

(2014.4.22)

抱歉!评论已关闭.