现在的位置: 首页 > 综合 > 正文

Jobdu 题目1144:Freckles

2017年11月17日 ⁄ 综合 ⁄ 共 1706字 ⁄ 字号 评论关闭

http://ac.jobdu.com/problem.php?pid=1144

题目描述:

    In an episode of the Dick Van Dyke show, little Richie connects the freckles on his Dad's back to form a picture of the Liberty Bell. Alas, one of the freckles turns out to be a scar, so his Ripley's engagement falls through. 
    Consider Dick's back to be a plane with freckles at various (x,y) locations. Your job is to tell Richie how to connect the dots so as to minimize the amount of ink used. Richie connects the dots by drawing straight lines between pairs, possibly lifting
the pen between lines. When Richie is done there must be a sequence of connected lines from any freckle to any other freckle. 

输入:

    The first line contains 0 < n <= 100, the number of freckles on Dick's back. For each freckle, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the freckle.

输出:

    Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the freckles.

样例输入:
3
1.0 1.0
2.0 2.0
2.0 4.0
样例输出:
3.41
#include <cstdio>
#include <algorithm>
#include <cmath>
using namespace std;

int Tree[101];
int findRoot(int x){
	if (Tree[x] == -1) return x;
	else{
		int tmp = findRoot(Tree[x]);
		Tree[x] = tmp;
		return tmp;
	}
}
struct Node{
	double x, y;
}node[101];
struct Edge{
	int a, b;
	double distance;
	bool operator < (const Edge &A) const{
		return distance < A.distance;
	}
}edge[10000];
double dis(Node a, Node b){
	return sqrt((a.x - b.x)*(a.x - b.x) + (a.y - b.y)*(a.y - b.y));
}

int main(){
	int n;
	while (scanf("%d", &n) != EOF){
		for (int i = 1; i <= n; i++){
			scanf("%lf%lf", &node[i].x, &node[i].y);
			Tree[i] = -1;
		}
		int index = 1;
		for (int i = 1; i < n; i++){
			for (int j = i + 1; j <= n; j++){
				edge[index].a = i;
				edge[index].b = j;
				edge[index++].distance = dis(node[i], node[j]);
			}
		}
		double ans = 0;
		sort(edge + 1, edge + 1 + n*(n - 1) / 2);
		for (int i = 1; i <= n*(n - 1) / 2; i++){
			int a = findRoot(edge[i].a);
			int b = findRoot(edge[i].b);
			if (a != b){
				Tree[a] = b;
				ans += edge[i].distance;
			}
		}
		printf("%.2lf\n", ans);
	}
	return 0;
}

抱歉!评论已关闭.