现在的位置: 首页 > 综合 > 正文

【HDU】 1540 Tunnel Warfare 线段树

2017年11月20日 ⁄ 综合 ⁄ 共 2824字 ⁄ 字号 评论关闭

Tunnel Warfare

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3888    Accepted Submission(s): 1460

Problem Description

During the War of Resistance Against Japan, tunnel warfare was carried out extensively in the vast areas of north China Plain. Generally speaking, villages connected by tunnels lay in a line. Except the
two at the ends, every village was directly connected with two neighboring ones.

Frequently the invaders launched attack on some of the villages and destroyed the parts of tunnels in them. The Eighth Route Army commanders requested the latest connection state of the tunnels and villages. If some villages are severely isolated, restoration
of connection must be done immediately!

 


Input

The first line of the input contains two positive integers n and m (n, m ≤ 50,000) indicating the number of villages and events. Each of the next m lines describes an event.

There are three different events described in different format shown below:

D x: The x-th village was destroyed.

Q x: The Army commands requested the number of villages that x-th village was directly or indirectly connected with including itself.

R: The village destroyed last was rebuilt.

 


Output

Output the answer to each of the Army commanders’ request in order on a separate line.
 


Sample Input
7 9 D 3 D 6 D 5 Q 4 Q 5 R Q 4 R Q 4
 


Sample Output
1 0 2 4
 


Source

POJ Monthly

传送门:【HDU】 1540 Tunnel Warfare

题目大意:
n个村庄在X轴上排成一列,从左到右依次编号1~n。m次操作。n,m <= 50000。
1.D x 摧毁编号为x的村庄。
2.Q x 查询编号为x的村庄直接或间接相连的村庄共有多少(包括自身)。
3.R    恢复最后摧毁的村庄。

题目分析:
很明显又是一题区间合并问题:每次更新单点,然后合并区间,维护区间最长前缀及后缀。对于操作R直接用栈保存就好了。最后在查询的时候不断合并就行了,蛮简单的就不多说了。

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std ;

typedef long long Int ;

#define rt l , r , o
#define ls ( o << 1 )
#define rs ( o << 1 | 1 )
#define lson l , m , ls
#define rson m + 1 , r , rs
#define mid ( ( l + r ) >> 1 )
#define root 1 , n , 1
#define clear( A , X ) memset ( A , X , sizeof A )

const int maxN = 50005 ;

int lmax[maxN << 2] , rmax[maxN << 2] ;//这题不需要mmax[]
int stack[maxN] , top ;
char ch[5] ;

int max ( const int X , const int Y ) {
	return X > Y ? X : Y ;
}

int min ( const int X , const int Y ) {
	return X < Y ? X : Y ;
}

void PushUp ( int l , int r , int o ) {
	int m = mid ;
	lmax[o] = lmax[ls] ; 
	if ( lmax[o] == m - l + 1 ) lmax[o] += lmax[rs] ;
	
	rmax[o] = rmax[rs] ;
	if ( rmax[o] == r - m ) rmax[o] += rmax[ls] ;
}

void Build ( int l , int r , int o ) {
	if ( l == r ) {
		lmax[o] = rmax[o] = 1 ;
		return ;
	}
	int m = mid ;
	Build ( lson ) ;
	Build ( rson ) ;
	PushUp ( rt ) ;
}

void Update ( int x , int v , int l , int r , int o ) {
	if ( l == r ) {
		lmax[o] = rmax[o] = v ;
		return ;
	}
	int m = mid ;
	if ( x <= m ) Update ( x , v , lson ) ;
	else 	      Update ( x , v , rson ) ;
	PushUp ( rt ) ;
}

int lnum , rnum ;

int Query ( int x , int l , int r , int o ) {
	if ( l == r ) {
		lnum = rnum = x ;
		return lmax[o] ;
	}
	int m = mid ;
	if ( x <= m ) {
		int ans = Query ( x , lson ) ;
		if ( !ans ) return 0 ;
		if ( rnum == m && lmax[rs] ) {
			rnum += lmax[rs] ;
			ans += lmax[rs] ;
		}
		return ans ;
	}
	else {
		int ans = Query ( x , rson ) ;
		if ( !ans ) return 0 ;
		if ( lnum == m + 1 && rmax[ls] ) {
			lnum -= rmax[ls] ;
			ans += rmax[ls] ;
		}
		return ans ;
	}
}

void work () {
	int n , m , x ;
	while ( ~scanf ( "%d%d" , &n , &m ) ) {
		Build ( root ) ;
		while ( m -- ) {
			scanf ( "%s" , ch ) ;
			if ( ch[0] == 'D' ) {
				scanf ( "%d" , &x ) ;
				Update ( x , 0 , root ) ;
				stack[top ++] = x ;
			}
			if ( ch[0] == 'R' ) {
				if ( 0 == top ) continue ;
				Update ( stack[-- top] , 1 , root ) ;
			}
			if ( ch[0] == 'Q' ) {
				scanf ( "%d" , &x ) ;
				printf ( "%d\n" , Query ( x , root ) ) ;
			}
		}
	}
}

int main () {
	work () ;
	return 0 ;
}

抱歉!评论已关闭.