现在的位置: 首页 > 综合 > 正文

HDU 4027 Can you answer these queries? 线段树 区间修改 区间查询

2017年11月20日 ⁄ 综合 ⁄ 共 3262字 ⁄ 字号 评论关闭

Can you answer these queries?

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 8122    Accepted Submission(s): 1845

Problem Description

A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance.
For every attack of our secret weapon, it could decrease the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants
to evaluate the effect of the weapon, so he asks you for help.
You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line.

Notice that the square root operation should be rounded down to integer.

 


Input

The input contains several test cases, terminated by EOF.
  For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000)
  The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 263.
  The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000)
  For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query
of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive.
 


Output

For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.
 


Sample Input
10 1 2 3 4 5 6 7 8 9 10 5 0 1 10 1 1 10 1 1 5 0 5 8 1 4 8
 


Sample Output
Case #1: 19 7 6
 


Source

The
36th ACM/ICPC Asia Regional Shanghai Site —— Online Contest

传送门:HDU 4027 Can you answer these queries?
题目大意:给你一串n个数的序列,每次修改对区间[L,R]内的数开平方,每次查询询问[L,R]内数的和。
题目分析:乍看之下可能无从下手,但是,由于每个数最多开7次平方就会收敛成1,也就是说,当一段区间被开平方的次数大于等于7时,则这段区间数的和就是R - L + 1。
根据这一性质,我们可以得到一种解决方案:对于修改,我们对于区间内的数不全为1的区间更新,直到遇到区间内的数全部为1的区间或者叶子结点为止。这样只要使用线段树,维护区间和的信息即可。

PS:额外注意一点,X可能大于Y。

代码如下:

#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std ;

#define lson l , m , o << 1
#define rson m + 1 , r , o << 1 | 1

typedef long long ll ;

const int maxN = 1000000 ;
const int oo = 0x3f3f3f3f ;

struct Node {
    int mark ;
    ll sum ;
} T[ maxN ] ;
int n ;

void swap ( int &X , int &Y ) {
    int tmp ;
    tmp =   X ;
    X   =   Y ;
    Y   = tmp ;
}

void PushUp ( int o ) {
    T[ o ].sum = T[ o << 1 ].sum + T[ o << 1 | 1 ].sum ;
}

void Build ( int l , int r , int o ) {
    T[ o ].mark = 0 ;
    if ( l == r ) scanf ( "%I64d" , &T[ o ].sum ) ;
    else {
        int m = ( l + r ) >> 1 ;
        Build ( lson ) ;
        Build ( rson ) ;
        PushUp ( o ) ;
    }
}

void Update ( int L , int R , int l , int r , int o ) {
    if ( T[ o ].sum == r - l + 1 ) return ;
    if ( l == r ) {
        T[ o ].sum = sqrt ( 1.0 * T[ o ].sum ) ;
        return ;
    }
    int m = ( l + r ) >> 1 ;
    if ( L <= m ) Update ( L , R , lson ) ;
    if ( m <  R ) Update ( L , R , rson ) ;
    PushUp ( o ) ;
}

ll Query ( int L , int R , int l , int r , int o ) {
    if ( L <= l && r <= R ) return T[ o ].sum ;
    ll ans = 0 ;
    int m = ( l + r ) >> 1 ;
    if ( L <= m ) ans += Query ( L , R , lson ) ;
    if ( m <  R ) ans += Query ( L , R , rson ) ;
    return ans ;
}
void work () {
    int ch , L , R , m ;
    Build ( 1 , n , 1 ) ;
    scanf ( "%d", &m ) ;
    while ( m -- ) {
        scanf ( "%d%d%d" , &ch , &L , &R ) ;
        if ( L > R ) swap ( L , R ) ;
        if ( ch == 0 ) Update ( L , R , 1 , n , 1 ) ;
        else printf ( "%I64d\n" , Query ( L , R , 1 , n , 1 ) ) ;
    }
}

int main () {
    int cas = 0 ;
    while ( ~scanf ( "%d" , &n ) ) {
        printf ( "Case #%d:\n" , ++ cas ) ;
        work () ;
        printf ( "\n" ) ;
    }
    return 0 ;
}

抱歉!评论已关闭.