现在的位置: 首页 > 综合 > 正文

HDU 1698 Just a Hook 线段树 成段替换

2017年11月20日 ⁄ 综合 ⁄ 共 2659字 ⁄ 字号 评论关闭

Just a Hook

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 15645    Accepted Submission(s): 7750

Problem Description

In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.



Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.

 


Input

The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents
the golden kind.
 


Output

For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
 


Sample Input
1 10 2 1 5 2 5 9 3
 


Sample Output
Case 1: The total value of the hook is 24.
 


Source

2008 “Sunline Cup” National
Invitational Contest

传送门:HDU 1698 Just a Hook
题目大意:给你一个区间[1...n],每次替换[L,R]的值为c,问最后整个区间的和是多少。
题目分析:线段树的成段替换模型,照着写就好了。

代码如下:

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std ;

#define clear( A , X ) memset ( A , X , sizeof A )
#define lson l , m , o << 1
#define rson m + 1 , r , o << 1 | 1

const int maxN = 1000000 ;

int sum[ maxN ] , set [ maxN ] ;

void PushUp ( int o ) {
	sum[ o ] = sum[ o << 1 ] + sum[ o << 1 | 1 ] ;
}

void PushDown ( int o , int c ) {
	if ( set[ o ] ) {
		set[ o << 1 ] = set[ o << 1 | 1 ] = set[ o ] ;
		sum[ o << 1 ] = set[ o << 1 ] * ( c - ( c >> 1 ) ) ;
		sum[ o << 1 | 1 ] = set[o << 1 | 1 ] * ( c >> 1 ) ;
		set[ o ] = 0 ;
	}
}

void Build ( int l , int r , int o ) {
	set[ o ] = 0;
	if ( l == r ) sum[ o ] = 1 ;
	else {
		int m = ( l + r ) >> 1 ;
		Build ( lson ) ;
		Build ( rson ) ;
		PushUp ( o ) ;
	}
}

void Update ( int L , int R , int c , int l , int r , int o ) {
	if ( L <= l && r <= R ) {
		set[ o ] = c ;
		sum[ o ] = c * ( r - l + 1 ) ;
		return ;
	}
	PushDown ( o , r - l + 1 ) ;
	int m = ( l + r ) >> 1 ;
	if ( L <= m ) Update ( L , R , c , lson ) ;
	if ( m < R ) Update ( L , R , c , rson ) ;
	PushUp ( o ) ;
}

int work () {
	int L , R , c , n , m ;
	scanf ( "%d%d" , &n , &m ) ;
	Build ( 1 , n , 1 ) ;
	for ( int i = 0 ; i < m ; ++ i ) {
		scanf ( "%d%d%d" , &L , &R , &c ) ;
		Update ( L , R , c , 1 , n , 1 ) ;
	}
	return sum[ 1 ] ;
}

int main () {
	int T , cas ;
	for ( scanf ( "%d" , &T ) , cas = 1 ; cas <= T ; ++ cas ) {
		printf ( "Case %d: The total value of the hook is %d.\n" , cas , work () ) ;
	}
	return 0 ;
}

抱歉!评论已关闭.