现在的位置: 首页 > 综合 > 正文

HDU/HDOJ 1171 Big Event in HDU 01背包、多重背包、母函数

2017年11月22日 ⁄ 综合 ⁄ 共 1746字 ⁄ 字号 评论关闭

Big Event in HDU

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8342    Accepted Submission(s): 2835

Problem Description
Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is
N (0<N<1000) kinds of facilities (different value, different kinds).
 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding
number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.
 

Output
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that
A is not less than B.
 

Sample Input
2 10 1 20 1 3 10 1 20 2 30 1 -1
 

Sample Output
20 10 40 40
 

直接把多重背包转化为01背包水过的。。

不过我也太水了。。

我的代码:

#include<stdio.h>
#include<string.h>

int a[5005],dp[250005];
int num,sum;

int max(int a,int b)
{
	if(a>b)
		return a;
	else
		return b;
}

int min(int a,int b)
{
	if(a>b)
		return b;
	else
		return a;
}

int main()
{
	int n,m,k,i,j;
	while(scanf("%d",&n)!=EOF)
	{
		if(n<0)
			break;
		num=0,sum=0;
		memset(dp,0,sizeof(dp));
		for(i=1;i<=n;i++)
		{
			scanf("%d%d",&m,&k);
			for(j=1;j<=k;j++)
				a[num++]=m;
			sum=sum+m*k;
		}
		for(i=0;i<num;i++)
			for(j=sum/2;j>=a[i];j--)
				dp[j]=max(dp[j],dp[j-a[i]]+a[i]);
		printf("%d %d\n",max(dp[sum/2],sum-dp[sum/2]),min(dp[sum/2],sum-dp[sum/2]));
	}
	return 0;
}

抱歉!评论已关闭.