现在的位置: 首页 > 综合 > 正文

HDOJ/HDU 1142 A Walk Through the Forest

2017年11月22日 ⁄ 综合 ⁄ 共 2627字 ⁄ 字号 评论关闭

 

A Walk Through the Forest

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2292    Accepted Submission(s): 838

Problem Description
Jimmy experiences a lot of stress at work these days, especially since his accident made working difficult. To relax after a hard day, he likes to walk home. To make things even nicer, his office is on one side of a forest, and his
house is on the other. A nice walk through the forest, seeing the birds and chipmunks is quite enjoyable.

The forest is beautiful, and Jimmy wants to take a different route everyday. He also wants to get home before dark, so he always takes a path to make progress towards his house. He considers taking a path from A to B to be progress if there exists a route from
B to his home that is shorter than any possible route from A. Calculate how many different routes through the forest Jimmy might take.
 

Input
Input contains several test cases followed by a line containing 0. Jimmy has numbered each intersection or joining of paths starting with 1. His office is numbered 1, and his house is numbered 2. The first line of each test case gives
the number of intersections N, 1 < N ≤ 1000, and the number of paths M. The following M lines each contain a pair of intersections a b and an integer distance 1 ≤ d ≤ 1000000 indicating a path of length d between intersection a and a different intersection
b. Jimmy may walk a path any direction he chooses. There is at most one path between any pair of intersections.
 

Output
For each test case, output a single integer indicating the number of different routes through the forest. You may assume that this number does not exceed 2147483647
 

Sample Input
5 6 1 3 2 1 4 2 3 4 3 1 5 12 4 2 34 5 2 24 7 8 1 3 1 1 4 1 3 7 1 7 4 1 7 5 1 6 7 1 5 2 1 6 2 1 0
 

Sample Output
2 4
 

Source
 
读了很久的题目。。
主要是后面的搜索部分,需要用到记忆优化搜索
 
我的代码:
#include<stdio.h>
#include<string.h>
#include<vector>
#include<algorithm>
#include<queue>
#define maxn 1005
#define inf 2147483647

using namespace std;

struct node
{
	int v;
	int len;
};
vector<node>map[maxn];
bool road[maxn][maxn];
int n,dis[maxn],dp[maxn];

void init()
{
	int i;
	for(i=0;i<=n;i++)
	{
		map[i].clear();
		dp[i]=-1;
		dis[i]=inf;
	}
	memset(road,0,sizeof(road));
}

void spfa(int s)
{
	int i;
	bool used[maxn];
	memset(used,0,sizeof(used));
	dis[s]=0;
	used[s]=true;
	queue<int>q;
	q.push(s);
	while(!q.empty())
	{
		int u=q.front();
		q.pop();
		used[u]=false;
		for(i=0;i<map[u].size();i++)
		{
			node p=map[u][i];
			if(dis[p.v]>dis[u]+p.len)
			{
				dis[p.v]=dis[u]+p.len;
				if(!used[p.v])
				{
					used[p.v]=true;
					q.push(p.v);
				}
			}
		}
	}
}

int dfs(int v)
{
	if(dp[v]!=-1)
		return dp[v];
	if(v==2)
		return 1;
	int i;
	dp[v]=0;
	for(i=1;i<=n;i++)
		if(road[v][i]&&dis[v]>dis[i])
			dp[v]=dp[v]+dfs(i);
	return dp[v];
}

int main()
{
	int i,m;
	int a,b,c,ans;
	node p;
	while(scanf("%d",&n)!=EOF)
	{
		if(n==0)
			break;
		init();
		scanf("%d",&m);
		for(i=1;i<=m;i++)
		{
			scanf("%d%d%d",&a,&b,&c);
			p.v=b;
			p.len=c;
			map[a].push_back(p);
			p.v=a;
			map[b].push_back(p);
			road[a][b]=true;
			road[b][a]=true;
		}
		spfa(2);
		ans=dfs(1);
		printf("%d\n",ans);
	}
	return 0;
}

抱歉!评论已关闭.