现在的位置: 首页 > 综合 > 正文

POJ 1207 HDOJ/HDU 1032 3n+1数链问题 绝对不水的解法

2017年11月22日 ⁄ 综合 ⁄ 共 3328字 ⁄ 字号 评论关闭

 

The 3n + 1 problem
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 39115   Accepted: 12294

Description

Problems in Computer Science are often classified as belonging to a certain class of problems (e.g., NP, Unsolvable, Recursive). In this problem you will be analyzing a property of an algorithm whose classification is not known
for all possible inputs.
Consider the following algorithm:
 

		1. 		 input n



		2. 		 print n



		3. 		 if n = 1 then STOP



		4. 		 		 if n is odd then   n <-- 3n+1



		5. 		 		 else   n <-- n/2



		6. 		 GOTO 2



Given the input 22, the following sequence of numbers will be printed 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1

It is conjectured that the algorithm above will terminate (when a 1 is printed) for any integral input value. Despite the simplicity of the algorithm, it is unknown whether this conjecture is true. It has been verified, however, for all integers n such that
0 < n < 1,000,000 (and, in fact, for many more numbers than this.)

Given an input n, it is possible to determine the number of numbers printed before the 1 is printed. For a given n this is called the cycle-length of n. In the example above, the cycle length of 22 is 16.

For any two numbers i and j you are to determine the maximum cycle length over all numbers between i and j.

Input

The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 10,000 and greater than 0.

You should process all pairs of integers and for each pair determine the maximum cycle length over all integers between and including i and j.

Output

For each pair of input integers i and j you should output i, j, and the maximum cycle length for integers between and including i and j. These three numbers should be separated by at least one space with all three numbers on one
line and with one line of output for each line of input. The integers i and j must appear in the output in the same order in which they appeared in the input and should be followed by the maximum cycle length (on the same line).

Sample Input

1 10
100 200
201 210
900 1000

Sample Output

1 10 20
100 200 125
201 210 89
900 1000 174

Source

 
这个题,很多人以为是水题。其实大家都没有想想这个题的其他解法
这个题,很多人说事水题的原因是:n太小。所以直接暴力就OK
确实,暴力可以过掉,而且搞不好还是0ms
但是如果n有100w这个时候该怎么暴力?
 
所以这个时候暴力就是不可取的了
可以观察到,如果要求22的数链长度,其实就是在11的长度上+1,那么要知道11的长度,就在34的长度上面+1,等等等等。。
所以这个题其实可以用记忆优化搜索非常快速的搜索出1到n的所有i的数链长度。
得到长度之后,就可以用线段树求某一个区间的最大值。这一步很显然
 
看看我的代码吧:
#include<stdio.h>
#include<string.h>
#define maxn 10000

struct node
{
	__int64 left;
	__int64 right;
	__int64 max;
};
__int64 dp[maxn+5];
node tree[3*maxn];

void dfs(__int64 n,__int64 num,__int64 id)
{
	if(n<maxn&&dp[n]!=-1)
	{
		dp[id]=dp[n]+num;
		return;
	}
	else
	{
		if(n&1)
		{
			n=n*3+1;
			dfs(n,num+1,id);
		}
		else
		{
			n=n/2;
			dfs(n,num+1,id);
		}
	}
}

__int64 max(__int64 a,__int64 b)
{
	if(a>b)
		return a;
	else
		return b;
}

void build(__int64 left,__int64 right,__int64 root)
{
	tree[root].left=left;
	tree[root].right=right;
	if(left==right)
	{
		tree[root].max=dp[left];
		return;
	}
	__int64 mid=(left+right)>>1;
	build(left,mid,root*2);
	build(mid+1,right,root*2+1);
	tree[root].max=max(tree[2*root].max,tree[2*root+1].max);
}

void init()
{
	__int64 i;
	memset(dp,-1,sizeof(dp));
	dp[1]=1;
	for(i=1;i<=maxn;i++)
		dfs(i,0,i);
	build(1,maxn,1);
}

void swap(__int64 &a,__int64 &b)
{
	__int64 temp;
	temp=a;
	a=b;
	b=temp;
}

__int64 search(__int64 left,__int64 right,__int64 root)
{
	if(tree[root].left==left&&tree[root].right==right)
		return tree[root].max;
	__int64 mid=(tree[root].left+tree[root].right)>>1;
	if(right<=mid)
		return search(left,right,root*2);
	else if(left>mid)
		return search(left,right,root*2+1);
	else
		return max(search(left,mid,root*2),search(mid+1,right,root*2+1));
}

int main()
{
	init();
	__int64 a,b;
	while(scanf("%I64d%I64d",&a,&b)!=EOF)
	{
		if(a>b)
		{
			swap(a,b);
			printf("%I64d %I64d %I64d\n",b,a,search(a,b,1));
		}
		else
		{
			printf("%I64d %I64d %I64d\n",a,b,search(a,b,1));
		}
	}
	return 0;
}

抱歉!评论已关闭.