现在的位置: 首页 > 综合 > 正文

POJ 1144 求关键点

2017年11月22日 ⁄ 综合 ⁄ 共 2702字 ⁄ 字号 评论关闭

 

Network
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 5883   Accepted: 2773

Description

A Telephone Line Company (TLC) is establishing a new telephone cable network. They are connecting several places numbered by integers from 1 to N . No two places have the same number. The lines are bidirectional and always connect
together two places and in each place the lines end in a telephone exchange. There is one telephone exchange in each place. From each place it is

possible to reach through lines every other place, however it need not be a direct connection, it can go through several exchanges. From time to time the power supply fails at a place and then the exchange does not operate. The officials from TLC realized that
in such a case it can happen that besides the fact that the place with the failure is unreachable, this can also cause that some other places cannot connect to each other. In such a case we will say the place (where the failure

occured) is critical. Now the officials are trying to write a program for finding the number of all such critical places. Help them.

Input

The input file consists of several blocks of lines. Each block describes one network. In the first line of each block there is the number of places N < 100. Each of the next at most N lines contains the number of a place followed
by the numbers of some places to which there is a direct line from this place. These at most N lines completely describe the network, i.e., each direct connection of two places in the network is contained at least in one row. All numbers in one line are separated

by one space. Each block ends with a line containing just 0. The last block has only one line with N = 0;

Output

The output contains for each block except the last in the input file one line containing the number of critical places.

Sample Input

5
5 1 2 3 4
0
6
2 1 3
5 4 6 2
0
0

Sample Output

1
2

Hint

You need to determine the end of one line.In order to make it's easy to determine,there are no extra blank before the end of each line.

Source

 
#include<stdio.h>
#include<algorithm>
#include<vector>
#include<string.h>
#define maxn 105

using namespace std;

int n,cnt;
vector<int>g[maxn];
bool cri[maxn],used[maxn];
int col[maxn],low[maxn],dfn[maxn];
int Index,root;

void init()
{
	int i;
	memset(col,0,sizeof(col));
	memset(low,0,sizeof(low));
	memset(dfn,0,sizeof(dfn));
	memset(used,0,sizeof(used));
	memset(cri,0,sizeof(cri));
	for(i=0;i<=n;i++)
		g[i].clear();
	Index=0,cnt=0,root=1;
}

int min(int a,int b)
{
	if(a>b)
		return b;
	else
		return a;
}

void tarjan(int u,int v)
{
	int i,tot=0,j;
	col[u]=1;
	Index++;
	dfn[u]=Index;
	low[u]=Index;
	for(i=0;i<g[u].size();i++)
	{
		j=g[u][i];
		if(col[j]==0)
		{
			tot++;
			tarjan(j,u);
			low[u]=min(low[u],low[j]);
			if(tot>1&&u==1)
				cri[u]=true;
			if(u!=1&&low[j]==dfn[u])
				cri[u]=true;
		}
		else if(u!=j)
			low[u]=min(low[u],dfn[j]);
	}
}

int main()
{
	int i,a,b;
	char t;
	while(scanf("%d",&n)!=EOF)
	{
		if(n==0)
			break;
		init();
		while(true)
		{
			scanf("%d",&a);
			if(a==0)
				break;
			while(true)
			{
				scanf("%c",&t);
				if(t=='\n')
					break;
				scanf("%d",&b);
				g[a].push_back(b);
				g[b].push_back(a);
			}
		}
		tarjan(1,-1);
		int ans=0;
		for(i=1;i<=n;i++)
			if(cri[i])
				ans++;
		printf("%d\n",ans);
	}
	return 0;
}

抱歉!评论已关闭.