现在的位置: 首页 > 综合 > 正文

POJ 1089 贪心算法

2017年11月22日 ⁄ 综合 ⁄ 共 1923字 ⁄ 字号 评论关闭
Intervals
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 5434   Accepted: 2133

Description

There is given the series of n closed intervals [ai; bi], where i=1,2,...,n. The sum of those intervals may be represented as a sum of closed pairwise non−intersecting intervals. The task is to find such representation with the minimal number of intervals. The intervals of this representation should be written in the output file in acceding order. We say that the intervals [a; b] and [c; d] are in ascending order if, and only if a <= b < c <= d.
Task
Write a program which:
reads from the std input the description of the series of intervals,
computes pairwise non−intersecting intervals satisfying the conditions given above,
writes the computed intervals in ascending order into std output

Input

In the first line of input there is one integer n, 3 <= n <= 50000. This is the number of intervals. In the (i+1)−st line, 1 <= i <= n, there is a description of the interval [ai; bi] in the form of two integers ai and bi separated by a single space, which are respectively the beginning and the end of the interval,1 <= ai <= bi <= 1000000.

Output

The output should contain descriptions of all computed pairwise non−intersecting intervals. In each line should be written a description of one interval. It should be composed of two integers, separated by a single space, the beginning and the end of the interval respectively. The intervals should be written into the output in ascending order.

Sample Input

5
5 6
1 4
10 10
6 9
8 10

Sample Output

1 4
5 10

Source

最先开始看到是区间,还以为是线段树的题目,结果后来发现原来排个序贪心一下就好了。

Source Code

Problem: 1089   User: bingshen
Memory: 528K   Time: 79MS
Language: C++   Result: Accepted
  • Source Code

    #include<stdio.h>
    #include<algorithm>
    
    using namespace std;
    
    struct invial
    {
    	int l;
    	int r;
    };
    invial a[50005];
    int n;
    
    bool cmp(invial x,invial y)
    {
    	if((x.l<y.l)||((x.l==y.l)&&(x.r<y.r)))
    		return true;
    	return false;
    }
    
    int max(int x,int y)
    {
    	if(x>y)
    		return x;
    	else
    		return y;
    }
    
    int main()
    {
    	int i,s,e;
    	scanf("%d",&n);
    	for(i=0;i<n;i++)
    		scanf("%d%d",&a[i].l,&a[i].r);
    	sort(a,a+n,cmp);
    	s=a[0].l;
    	e=a[0].r;
    	for(i=0;i<n-1;i++)
    	{
    		if(e<a[i+1].l)
    		{
    			printf("%d %d/n",s,e);
    			s=a[i+1].l;
    			e=a[i+1].r;
    		}
    		else
    			e=max(a[i+1].r,e);
    	}
    	printf("%d %d/n",s,e);
    	return 0;
    }

抱歉!评论已关闭.