现在的位置: 首页 > 综合 > 正文

HDU 1272 判断树

2017年11月22日 ⁄ 综合 ⁄ 共 1682字 ⁄ 字号 评论关闭
文章目录

小希的迷宫

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 20   Accepted Submission(s) : 4

Font: Times New Roman | Verdana | Georgia

Font Size:

Problem Description

上次Gardon的迷宫城堡小希玩了很久(见Problem B),现在她也想设计一个迷宫让Gardon来走。但是她设计迷宫的思路不一样,首先她认为所有的通道都应该是双向连通的,就是说如果有一个通道连通了房间A和B,那么既可以通过它从房间A走到房间B,也可以通过它从房间B走到房间A,为了提高难度,小希希望任意两个房间有且仅有一条路径可以相通(除非走了回头路)。小希现在把她的设计图给你,让你帮忙判断她的设计图是否符合她的设计思路。比如下面的例子,前两个是符合条件的,但是最后一个却有两种方法从5到达8。

Input

输入包含多组数据,每组数据是一个以0 0结尾的整数对列表,表示了一条通道连接的两个房间的编号。房间的编号至少为1,且不超过100000。每两组数据之间有一个空行。

整个文件以两个-1结尾。

Output

对于输入的每一组数据,输出仅包括一行。如果该迷宫符合小希的思路,那么输出"Yes",否则输出"No"。

Sample Input

6 8  5 3  5 2  6 4
5 6  0 0

8 1  7 3  6 2  8 9  7 5
7 4  7 8  7 6  0 0

3 8  6 8  6 4
5 3  5 6  5 2  0 0

-1 -1

Sample Output

Yes
Yes
No

Author

Gardon

 

感觉上数据有问题。

我想法比较简洁,直接判断边的数量是否为点的数量-1就OK了先开始死活不过。然后在网上找了下,看他们特判了0 0.好吧我疏忽了于是加了特判,还是WA。然后我又继续比对别人的代码,以及我自己的代码。我发现,网上有一个人的思路和我是一样的。但是他没有考虑重边。而我还特意用了map来标记重边。于是我把重边标记去掉,然后就过了。

注释的部分比较冤。。

 

我的代码:

#pragma warning(disable:4786)
#include<stdio.h>
#include<iostream>
#include<string.h>
#include<map>
#include<stdlib.h>
#include<algorithm>

using namespace std;

map<pair<int,int>,bool>edge;
map<int,bool>node;

int main()
{
	int a,b;
	int n,m;
	while(scanf("%d%d",&a,&b)!=EOF)
	{
		n=0,m=0;
		edge.clear();
		node.clear();
		if(a==-1&&b==-1)
			break;
		if(a==0&&b==0)
		{
			printf("Yes\n");
			continue;
		}
//		if(edge[make_pair(a,b)]==false)
//		{
//			edge[make_pair(a,b)]=true;
//			edge[make_pair(b,a)]=true;
//			m++;
//		}
		m++;
		if(node[a]==false)
		{
			node[a]=true;
			n++;
		}
		if(node[b]==false)
		{
			node[b]=true;
			n++;
		}
		while(true)
		{
			scanf("%d%d",&a,&b);
			if(a==0&&b==0)
			{
				if(m==n-1)
					printf("Yes\n");
				else
					printf("No\n");
				break;
			}
			m++;
//			if(edge[make_pair(a,b)]==false)
//			{
//				edge[make_pair(a,b)]=true;
//				edge[make_pair(b,a)]=true;
//				m++;
//			}
			if(node[a]==false)
			{
				node[a]=true;
				n++;
			}
			if(node[b]==false)
			{
				node[b]=true;
				n++;
			}
		}
	}
	return 0;
}

抱歉!评论已关闭.